Bridgestone Blizzak will not mount! - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-11-2015, 07:51 AM Thread Starter
Learners License
 
Join Date: Nov 2015
Location: Pickering, ON, Canada
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Bridgestone Blizzak will not mount!

So my newly acquired 6 came with a decent set of snow tires. The previous owner was having the tires put on the OEM rims and replaced yearly. I can't connect with the idea of paying to do something multiple times and don't mind the look of steel rims for winter.

I hunted for and found a set of rims to fit and had the tires installed. Three went on without a fuss and one wheel will not sit properly. That is, the bead will not find its way to the right spot in a section of about 10". This tire was taken off and tried on the other rims and it is the tire that is presenting the problem.

Two shops have been struggling with no success yet, although one is still trying. Anyone else have this problem? What did you do?

Tires are 215/50/r17 on 17" rims x 6.5 with 5 - 114.3mm steelies.
JZ67 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-11-2015, 09:24 PM
Mazda Guru
 
GerryB's Avatar
 
Join Date: Oct 2007
Location: Mundelein, IL
Posts: 4,116
Mentioned: 40 Post(s)
Tagged: 0 Thread(s)
Quoted: 346 Post(s)
Thanks: 73
Thanked 226 Times in 216 Posts
Groans: 1
Groaned at 1 Time in 1 Post
iTrader: 1 reviews
I had a new set mounted last year. The installing shop had to inflate to about 70psi multiple times before the bead would seat. Blizzaks are very stiff at the bead and need persuasion. This should not be a mystery to a good shop.

Sent from my HTC One using Tapatalk
GerryB is online now  
post #3 of 3 (permalink) Old 11-12-2015, 07:28 AM Thread Starter
Learners License
 
Join Date: Nov 2015
Location: Pickering, ON, Canada
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
The shop that it is in now said the same thing and he is trying, determined to succeed actually. Had it up to 80 psi multiple times without any luck.
JZ67 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome