Intro, and seeking help - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 01-22-2019, 07:24 PM Thread Starter
Learners License
 
Join Date: Jan 2018
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Intro, and seeking help

Hello, i have a 2005 Mazda 6 V6 3.0L i love the car but it was involved in a wreck and it's been hell figuring out it's main problem (Running good while cold but 5-10 minutes later stalling) Has trouble climbing in rpm's, took it to my auto shop and had the wiring harness replaced, said it threw code p0606 (bad ecu) but the code is gone and i can't seem to get another check engine light thought it's running awful.
Imperial is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-22-2019, 11:24 PM
Registered User
 
jman1200's Avatar
 
Join Date: Dec 2016
Location: Ontario/Canada
Posts: 385
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Thanks: 6
Thanked 36 Times in 34 Posts
Groans: 3
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Where has it hit? Pics? What was removed or replaced when repaired?

2016-Current: 2006 Mazda 6 GT - V6 - Hatchback w/NAV

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008-2015: 2004 Mazda 6 GS - I4

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jman1200 is offline  
post #3 of 6 (permalink) Old 01-23-2019, 11:32 AM
Shiro Shinobi

 
Byakuya's Avatar
 
Join Date: Dec 2011
Location: Taxachusetts
Posts: 16,481
Mentioned: 778 Post(s)
Tagged: 5 Thread(s)
Quoted: 2873 Post(s)
Thanks: 1,961
Thanked 4,058 Times in 2,850 Posts
Groans: 0
Groaned at 16 Times in 16 Posts
Garage
iTrader: 0 reviews
^^ Gonna need some more info before we can try to figure out what's going on.

'Running Awful' can be a symptom of any of the following:

Bad/Dirty MAF
Dirty Throttle Body
Bad/Clamped PCV Valve/Hose
Incorrectly sealed intake
Bad wiring/grounds
...etc

Current:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Sold:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 3rd Generation
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A gov't big enough to give you anything you want is big enough to take all you have.
"Camry: For Drivers Without a Soul." - Mz6GreyGhost
For your 'will these tires fit' needs:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Need a Part Number? Find it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Byakuya is online now  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-16-2019, 12:29 PM Thread Starter
Learners License
 
Join Date: Jan 2018
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by Byakuya View Post
^^ Gonna need some more info before we can try to figure out what's going on.

'Running Awful' can be a symptom of any of the following:

Bad/Dirty MAF
Dirty Throttle Body
Bad/Clamped PCV Valve/Hose
Incorrectly sealed intake
Bad wiring/grounds
...etc
Narrowed it dosn, got another cel and it was barometric pressure sensor, my cats are plugged because MAZDA IS A COMEDIAN PUTTING 4 CATS ON THIS CAR just ordered an aftermarket exhaust system that deletes 3 cats.
Attached Thumbnails
Click image for larger version

Name:	6sOEMHeaders_1550338131608.jpg
Views:	23
Size:	16.2 KB
ID:	226438  
Attached Images
 
Imperial is offline  
post #5 of 6 (permalink) Old 02-16-2019, 12:33 PM Thread Starter
Learners License
 
Join Date: Jan 2018
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
And btw it was the front-right side hit these are NOT current pics, i replaced everything and completely rebuilt and repainted the car, looks mint but drives like it wants to kill itself. 😕😔
Attached Thumbnails
Click image for larger version

Name:	20180707_191445_1550338304057.jpg
Views:	11
Size:	253.3 KB
ID:	226440   Click image for larger version

Name:	20180707_191452_1550338367009.jpg
Views:	10
Size:	212.5 KB
ID:	226442  
Imperial is offline  
post #6 of 6 (permalink) Old 02-16-2019, 12:34 PM Thread Starter
Learners License
 
Join Date: Jan 2018
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by jman1200 View Post
Where has it hit? Pics? What was removed or replaced when repaired?
front right was hit.
Imperial is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome