At wits end. 08 Mazda6. Right turn signal activates Hazzards - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-05-2018, 12:15 PM Thread Starter
Learners License
 
Join Date: Dec 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
At wits end. 08 Mazda6. Right turn signal activates Hazzards

Hello All, new guy here.

I just paid off my 08 Mazda 6 a few months ago, and got brand new tires a week ago. Wouldn't you know it, yesterday I started having problems. For some reason, every time I activate my right turn signal, my hazards come on. My left signal works fine. I disconnected the common ground block just below my engine bay fuse box, and it did seem a little corroded, so i cleaned it with CRC electronics cleaner, and used a wire brush to clean the tab that is used to attach it to the frame. Still have the same problem. Everything else seems to be working fine, except my auto portion of my drivers side window button doesnt work (where you push it down once and it rolls all the way down on its own), but it does roll up and down fine while holding the switch up/down.

While the turn signal/hazard light issue is mostly consistent, it does seem to correct every once in a while and work fine (say, every 25th time using the signal, it will work fine, the other 24 times it turns on my hazards).

Any Ideas?
sixstringhook is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-05-2018, 02:28 PM
Registered User
 
Trippp's Avatar
 
Join Date: May 2009
Location: North Carolina
Posts: 728
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 140 Post(s)
Thanks: 32
Thanked 85 Times in 67 Posts
Groans: 4
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Throwing this out there... Maybe it’s the steering column switch, possibly a short is activating left and right signals together?

'18 Machine Gray GT Reserve
Trippp is offline  
post #3 of 5 (permalink) Old 12-05-2018, 04:39 PM Thread Starter
Learners License
 
Join Date: Dec 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I did think about that, and I tried spraying CRC electronics cleaner down in, but I have not yet pulled it out to check it.
sixstringhook is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 12-06-2018, 12:04 PM Thread Starter
Learners License
 
Join Date: Dec 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Well, last night was kind of a whirlwind of issues. When I left work, twice on my way home the car just died. I was able to put it in neutral and start it again without issue though. When I got home, I pulled the air cleaner box out to get better access to wiring. I pulled the common ground block and cleaned again, and put the ground leads into vinegar to clean of oxidation and cleaned with CRC again. still no luck. I opened my steering column and pulled the control arm out and cleaned it out, still having the same problem. I also pulled the turn signal bulb assembly and checked it out. the contacts seemed a little dirty, so i cleaned those, and there is no sign that the bulb is bad (both of the fillaments are in place).
sixstringhook is offline  
post #5 of 5 (permalink) Old 12-06-2018, 03:58 PM Thread Starter
Learners License
 
Join Date: Dec 2018
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
well, i decided to go ahead and buy a BCM. Bought a used one, we will see how that works. After doing some research, apparently the 2008 mazda 6 is prone to water leaking via the hood release lever cable, and drips right down on to the BCM. It kind of fits because 2 weeks ago it was raining pretty heavily where I am and i felt water dripping on to my left leg right under the BCM. Hope this fixes it.
sixstringhook is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome