Mazda 6 trans issue - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-05-2018, 04:42 AM Thread Starter
Learners License
 
Join Date: Dec 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Mazda 6 trans issue

Hi. I am new here and desperately seeking some advice. I have a 2004 auto Mazda 6 that has seemed to have pooped itself.. transmission suspected. The at light was coming on very cold mornings would get rough starts. Took it to a shop and they flushed it. The trans oil looked dark. Had that done the next morning same thing. Took it to another place and he changed some codes. But the problem persisted which was it would be make a noise when starting and acceleration and power seemed very decreased. It would also completely stall when idle such as at lights or intersections. If left idle more than 10 secs the car would stall. It's like you constantly tly has to press the pedal. This would be more prominent when aircon was on. Obvious acceleration and power loss until one day it just stopped and decided to only go in reverse. My question is do I need a new transmission or can this be fixed and possibly a speed sensor or solenoid problem. Any ideas would help. I wanna know if it's able to be fixed. I don't trust the trans guys as they never fixed the problem . Thanks
Sof88 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-05-2018, 05:17 AM
Registered User
 
Archerfish's Avatar
 
Join Date: Oct 2018
Location: Southeast Asia
Posts: 403
Mentioned: 5 Post(s)
Tagged: 1 Thread(s)
Quoted: 136 Post(s)
Thanks: 9
Thanked 24 Times in 22 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I had a similar experience but with our CR-V 98. The car will downshift automatically at random times. This occurred for about a month or so until I one day it switched​ to neutral. The gear shifter is still in D but the transmission is in neutral. I was able to drive until I got to my destination but the transmission finally died.

I decided to buy a reconditioned transmission and so it has been running for about 2 years.

For a twenty year old car, I have no complains.
Archerfish is online now  
post #3 of 3 (permalink) Old 12-05-2018, 06:18 AM Thread Starter
Learners License
 
Join Date: Dec 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by Archerfish View Post
I had a similar experience but with our CR-V 98. The car will downshift automatically at random times. This occurred for about a month or so until I one day it switched​ to neutral. The gear shifter is still in D but the transmission is in neutral. I was able to drive until I got to my destination but the transmission finally died.

I decided to buy a reconditioned transmission and so it has been running for about 2 years.

For a twenty year old car, I have no complains.
Yeah I'm really hoping not to have to buy a transmission. I figured since it still goes in reverse maybe it's something else. It was stalling but shifting up wasn't a problem except for the acceleration part of it.
Sof88 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome