Low beam head lights not working - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 16 (permalink) Old 04-13-2010, 09:11 PM Thread Starter
Learners License
 
Join Date: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Low beam head lights not working

I have a 2006 Mazda 6, went to leave for work yesterday morning & my low beam head lights didn't come on. The high beams works, as well as all other lights on the car. Changed the head lights & checked all fuses, seem to be good. I have no clue what the problem can be. Can anyone help me with this? I'd rather not have to take it to the dealership & pay $75 an hour if I can help it.
MJM6 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 04-14-2010, 08:05 AM
Registered User
 
mwalker46's Avatar
 
Join Date: Jul 2008
Location: Blenheim, Ontario
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
every bulb has a ground wire on it, check to see if you have any loose wires that connect to the low beam, it'll be its owe seprate wire
mwalker46 is offline  
post #3 of 16 (permalink) Old 04-14-2010, 11:12 AM Thread Starter
Learners License
 
Join Date: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Thank you, I'll try that. I was also told that I could only replace the head light bulbs with factory bulbs I had to purchase at the Mazda dealership, that because I replaced the bulbs with ones I purchased from AutoZone, that is the reason they are not working. I'm not sure if I believe since, the owners manual also states they have to be replaced at the dealership, due to the complexity of it, I'm a woman and figured it out, thanks to directions I found on here. Feel they are just trying to get money out of me.
MJM6 is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 04-14-2010, 11:40 AM
Registered User
 
TalonTsi90's Avatar
 
Join Date: Apr 2010
Location: Northern KY
Posts: 485
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Thanks: 11
Thanked 23 Times in 23 Posts
Groans: 5
Groaned at 7 Times in 7 Posts
iTrader: 0 reviews
Well, do you have the HID or Xenon's? Makes a big difference. If you have regular Xenon's, i highly recommend Sylvania Silver Stars. Much worth the $40/pair price tag.

2006 6 Hatch Grand Touring 5spd Sunroof


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TalonTsi90 is offline  
post #5 of 16 (permalink) Old 04-14-2010, 12:26 PM Thread Starter
Learners License
 
Join Date: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Question is do I have to purchase the bulbs from Mazda directly? I was told they are still not working because I replaced them with bulbs I purchased from AutoZone. I don't see where I purchased them from making a difference & that being the reason they are not working.
MJM6 is offline  
post #6 of 16 (permalink) Old 04-14-2010, 12:29 PM
Registered User
 
Join Date: Feb 2009
Location: New Jersey
Posts: 658
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 4
Thanked 46 Times in 34 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by MJM6 View Post
Question is do I have to purchase the bulbs from Mazda directly? I was told they are still not working because I replaced them with bulbs I purchased from AutoZone. I don't see where I purchased them from making a difference & that being the reason they are not working.
it doesnt. dealerships just want to make money.

2009 Mazda 6 - Performance White V6

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ankit69 is offline  
post #7 of 16 (permalink) Old 04-14-2010, 12:33 PM
Registered User
 
TalonTsi90's Avatar
 
Join Date: Apr 2010
Location: Northern KY
Posts: 485
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Thanks: 11
Thanked 23 Times in 23 Posts
Groans: 5
Groaned at 7 Times in 7 Posts
iTrader: 0 reviews
In this instance, Stealership is a more appropriate name

But, no, you dont HAVE to buy them there, unless NO ONE else has them. Which, in this case, is not true.

2006 6 Hatch Grand Touring 5spd Sunroof


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TalonTsi90 is offline  
post #8 of 16 (permalink) Old 04-14-2010, 12:46 PM Thread Starter
Learners License
 
Join Date: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
That's what I thought also. Thank you. Do you know how to change the headlight switch? I can't seem to find directions on that anywhere
MJM6 is offline  
post #9 of 16 (permalink) Old 04-14-2010, 12:56 PM
Registered User
 
TalonTsi90's Avatar
 
Join Date: Apr 2010
Location: Northern KY
Posts: 485
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Thanks: 11
Thanked 23 Times in 23 Posts
Groans: 5
Groaned at 7 Times in 7 Posts
iTrader: 0 reviews
Im not exactly sure, but im thinking youll have to pull the steering wheel. If not, at least take off the trim collar and go from there. One guy is selling the turn signal piece, maybe he can tell you how.

2006 6 Hatch Grand Touring 5spd Sunroof


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
TalonTsi90 is offline  
post #10 of 16 (permalink) Old 04-16-2010, 01:10 PM Thread Starter
Learners License
 
Join Date: Apr 2010
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I have fixed the problem, it was a loose wire. Thanks for all the advice
MJM6 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome