GPS mulfunction - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 16 (permalink) Old 09-05-2013, 07:00 AM Thread Starter
Registered User
 
Join Date: Mar 2013
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
GPS mulfunction

Recently, I found my GPS not working properly. At low speed or stop, the GPS has random pointing. That means, when I stop at a red light, the car would suddenly think I was on the cross road or facing backward. This result in annoying rerouting or sometime freeze.

I upgraded the system in early July and the car is 6 month old with around 6k miles. Car parks in an underground lot.

Any idea to fix it?
leedstao is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 09-05-2013, 07:59 AM
Shiro Shinobi

 
Byakuya's Avatar
 
Join Date: Dec 2011
Location: Taxachusetts
Posts: 15,903
Mentioned: 747 Post(s)
Tagged: 4 Thread(s)
Quoted: 2710 Post(s)
Thanks: 1,923
Thanked 3,981 Times in 2,797 Posts
Groans: 0
Groaned at 15 Times in 15 Posts
Garage
iTrader: 0 reviews
Sounds like it's getting a mixed/weak signal and therefore is not sure which direction you're facing. Was it cloudy/overcast when this was happening, or were you in a remote area?

For the most part mine does not do this, but I do find that sometimes it's not quite sure which direction you're pointing because it's trying to predict where you're going and it can't.

Current:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Sold:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 3rd Generation
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A gov't big enough to give you anything you want is big enough to take all you have.
"Camry: For Drivers Without a Soul." - Mz6GreyGhost
For your 'will these tires fit' needs:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Need a Part Number? Find it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Byakuya is online now  
post #3 of 16 (permalink) Old 09-05-2013, 08:43 AM
Registered User
 
Join Date: Sep 2008
Location: Maryland
Posts: 368
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 76 Post(s)
Thanks: 18
Thanked 83 Times in 67 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 6 reviews
Quote:
Originally Posted by leedstao View Post
Recently, I found my GPS not working properly. At low speed or stop, the GPS has random pointing. That means, when I stop at a red light, the car would suddenly think I was on the cross road or facing backward. This result in annoying rerouting or sometime freeze.

I upgraded the system in early July and the car is 6 month old with around 6k miles. Car parks in an underground lot.

Any idea to fix it?
Do you have anything on top of your dash that could be blocking the GPS antenna? The roof antenna is not the GPS antenna.

2014 Mazda 6 Grand Touring Liquid Silver
Move.Over is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old 09-05-2013, 10:56 AM Thread Starter
Registered User
 
Join Date: Mar 2013
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by Byakuya View Post
Sounds like it's getting a mixed/weak signal and therefore is not sure which direction you're facing. Was it cloudy/overcast when this was happening, or were you in a remote area?

For the most part mine does not do this, but I do find that sometimes it's not quite sure which direction you're pointing because it's trying to predict where you're going and it can't.
I guess it is more like a random noise. When I drive on a straight road, my car icon in the NAV will move front and back it self. Sometime it shows me on a parallel road at least 50 yards away. When you stop, the speed shows 1 or 2 mph randomly also.

Further information, when the GPS goes wrong, it does show waiting for valid GPS signal in the center bottom.

BTW, The weather should not be the reason, I had this problem everyday for the past 1 month now and both in city and on open highway.

Last edited by leedstao; 09-05-2013 at 11:00 AM.
leedstao is offline  
post #5 of 16 (permalink) Old 09-05-2013, 10:56 AM Thread Starter
Registered User
 
Join Date: Mar 2013
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by Move.Over View Post
Do you have anything on top of your dash that could be blocking the GPS antenna? The roof antenna is not the GPS antenna.
Could you tell me where the antenna locates? Thank you.
leedstao is offline  
post #6 of 16 (permalink) Old 09-05-2013, 10:59 AM
Registered User
 
ForzaEsEs26's Avatar
 
Join Date: Mar 2013
Location: NJ
Posts: 318
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 122 Post(s)
Thanks: 63
Thanked 80 Times in 58 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Garage
iTrader: 0 reviews
Quote:
Originally Posted by leedstao View Post
Could you tell me where the antenna locates? Thank you.
It's behind the glove compartment I believe.

________________


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ForzaEsEs26 is offline  
post #7 of 16 (permalink) Old 09-05-2013, 11:02 AM
Shiro Shinobi

 
Byakuya's Avatar
 
Join Date: Dec 2011
Location: Taxachusetts
Posts: 15,903
Mentioned: 747 Post(s)
Tagged: 4 Thread(s)
Quoted: 2710 Post(s)
Thanks: 1,923
Thanked 3,981 Times in 2,797 Posts
Groans: 0
Groaned at 15 Times in 15 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by leedstao View Post
I guess it is more like a random noise. When I drive on a straight road, my car icon in the NAV will move front and back it self. Sometime it shows me on a parallel road at least 50 yards away. When you stop, the speed shows 1 or 2 mph randomly also.

Further information, when the GPS goes wrong, it does show waiting for valid GPS signal in the center bottom.

BTW, The weather should not be the reason, I had this problem everyday for the past 1 month now and both in city and on open highway.
That's odd then and certainly shouldn't be happening. I'd try backing up the software on the card and updating the firmware on the device. Since updating, I've noticed my unit acting a bit better and even the iPhone integration has been working much better.

Current:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, Sold:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, 3rd Generation
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A gov't big enough to give you anything you want is big enough to take all you have.
"Camry: For Drivers Without a Soul." - Mz6GreyGhost
For your 'will these tires fit' needs:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Need a Part Number? Find it
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Byakuya is online now  
post #8 of 16 (permalink) Old 09-05-2013, 04:08 PM
Registered User
 
Join Date: Sep 2012
Location: Red Deer, Alberta
Posts: 114
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Thanks: 4
Thanked 39 Times in 20 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
The GPS antenna is under the center speaker grill on top of the dash. I know this for certain because I have already replaced my factory headunit for a different one.
GeraldEGB is offline  
post #9 of 16 (permalink) Old 09-05-2013, 04:12 PM
Registered User
 
Drizzoh's Avatar
 
Join Date: Aug 2007
Location: AZ
Posts: 2,573
Mentioned: 38 Post(s)
Tagged: 0 Thread(s)
Quoted: 335 Post(s)
Thanks: 108
Thanked 332 Times in 279 Posts
Groans: 1
Groaned at 8 Times in 7 Posts
iTrader: 0 reviews
Send a message via AIM to Drizzoh Send a message via MSN to Drizzoh Send a message via Yahoo to Drizzoh
Is the car not under warranty for some reason? Any problems with a car that new, I'd just bring it to Mazda and have them fix it for free. That is, after all, the point of a warranty.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Andrew |

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Drizzoh is offline  
post #10 of 16 (permalink) Old 09-07-2013, 06:14 AM Thread Starter
Registered User
 
Join Date: Mar 2013
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Called the Mazda and Tomtom today. Tomtom suggest a soft-refresh. Turn off the car and remove the SD card for 20 seconds. The same tricks as pull the power supply for your cable modem. Works fine at this moment.
leedstao is offline  
Sponsored Links
Advertisement
 
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome