CEL Code P2097, 2010 6 2.5 - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-30-2016, 02:42 PM Thread Starter
Registered User
 
Snyperx's Avatar
 
Join Date: May 2013
Location: Wisconsin
Posts: 233
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Thanks: 48
Thanked 17 Times in 15 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Exclamation CEL Code P2097, 2010 6 2.5

All,
Hoping to get some help. Went to leave my son's Lacrosse game and the CEL light came on. Got home and ran Torque. PCM is showing a P2097 code being stored.

Fault log report generated by Torque for Android
=================================================

Vehicle VIN: 1YVHZ8CH2A5M03291
Vehicle Manufacturer: Mazda
Vehicle Calibration ID: L51

Current Fault Log
------------------
P2097: Post Catalyst Fuel Trim System Too Rich bank1

Pending Fault Log
------------------
ECU reports no pending faults

Historic Fault Log
------------------
ECU reports no historic faults
Other discovered fault codes
(possibly pending, current or manufacturer specific)
----------------------------------------------------
ECU reports no other fault codes logged


Also grabbed a freeze frame with the following:

Freeze frame report generated by Torque for Android
================================================== =======

Vehicle VIN: 1YVHZ8CH2A5M03291
Vehicle Manufacturer: Mazda
Vehicle Calibration ID: L51

Freeze frame information:
------------------
Fuel Status = 0 byte
Engine Load = 22.745 %
Engine Coolant Temperature = 192.2 F
Fuel Trim Bank 1 Short Term = 8.594 %
Fuel Trim Bank 1 Long Term = -0.781 %
Intake Manifold Pressure = 5.076 psi
Engine RPM = 669 rpm
Speed (OBD) = 7.456 mph
Timing Advance = 15
Intake Air Temperature = 62.6 F
Mass Air Flow Rate = 24.064 cfm
Throttle Position(Manifold) = 12.549 %
Run time since engine start = 360 s
EGR Commanded = 0 %
Fuel Level (From Engine ECU) = 100 %
Distance travelled since codes cleared = 18.641 miles
Evap System Vapour Pressure = -328 Pa
Barometric pressure (from vehicle) = 14.214 psi
Catalyst Temperature (Bank 1,Sensor 1) = 1,193.54 F
Voltage (Control Module) = 13.781 V
Engine Load(Absolute) = 18.039 %
Commanded Equivalence Ratio(lambda) = 1.018
Relative Throttle Position = 2.353 %
Ambient air temp = 60.8 F
Absolute Throttle Position B = 12.549 %
Accelerator PedalPosition D = 15.686 %
Accelerator PedalPosition E = 7.451 %

I am looking at a new O2 sensor(s)? OR something else? Exhaust leak? Car seems to idle and drive without issue.Thanks!!

Current:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Previous: 2010 Mazda 6 i Touring

Last edited by Snyperx; 04-30-2016 at 04:37 PM.
Snyperx is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome