eBay SD NAV card not reading in 17' Mazda 6 touring - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 17 (permalink) Old 05-17-2019, 02:05 AM Thread Starter
Learners License
 
crazy_raccoon's Avatar
 
Join Date: May 2019
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
eBay SD NAV card not reading in 17' Mazda 6 touring

I purchased a brand new SD card that has the 2018 update for my '17 Mazda 6 Touring and it doesn't seem to load up at all when I insert the card. I'm new to this platform so I may have missed something. All I know is;

- It's one of the latest cards from last year (I dont have part number on hand).
- Nothing on the screen happens when I load the SD card. No error messages, zip, notta!
- I followed practically all the plug and play video directions on YouTube and still nothing.
- Even on the NAV screen it still just shows the compass and grid coordinates.
- The SD card is not in the locked position.

I'm not sure if I got a faulty card or if i have to do a firmware update (which I'm still clueless on how). Any suggestions would surely be appreciated from the community. Also, in case the card is bad the seller did message me back about returning it and exchanging if I have to go that route.
crazy_raccoon is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 05-17-2019, 11:55 AM
Registered User
 
dcoulombe's Avatar
 
Join Date: Jan 2012
Location: QC, Canada
Posts: 151
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Thanks: 47
Thanked 16 Times in 13 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Maybe try to read the sdcard with a PC to see if it's corrupted. Or install the mazda software and try to update the files.

http://infotainment.mazdahandsfree.c...language=en-US


Sent from my iPhone using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dcoulombe is online now  
post #3 of 17 (permalink) Old 05-17-2019, 02:04 PM
Registered User
 
b1lk1's Avatar
 
Join Date: Sep 2015
Location: Lindsay, Ontario
Posts: 941
Mentioned: 39 Post(s)
Tagged: 2 Thread(s)
Quoted: 312 Post(s)
Thanks: 37
Thanked 82 Times in 77 Posts
Groans: 20
Groaned at 2 Times in 2 Posts
Garage
iTrader: 0 reviews
If it came from China toss it in the bin.


Get it the proper way from a dealer and you won't have these issues. Before you cry about the price you already knew it was not gonna be cheap to upgrade or you did not do any homework before you bought the car.


Ebay is a royal shithole as of late, most likely you got taken.

2004 Mazda 6s 3.0 5dr. 5spd never ending money vacuum project:
CP-E headers w/catted mid + Magnaflow carback/AEM CAI/3.7L TB/Speed6 springs/RX-8 wheels
AWR 70D Enginemount/CP-E Dogbone/Custom urethane stock trans mount
Ralco shortshifter/Bose w/Auxmod/sharkfin antenna/lots of little things...
b1lk1 is offline  
Sponsored Links
Advertisement
 
post #4 of 17 (permalink) Old 05-17-2019, 04:50 PM
Registered User
 
mirage_i's Avatar
 
Join Date: Jun 2018
Posts: 57
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Thanks: 0
Thanked 9 Times in 8 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by crazy_raccoon View Post
I purchased a brand new SD card that has the 2018 update for my '17 Mazda 6 Touring and it doesn't seem to load up at all when I insert the card. I'm new to this platform so I may have missed something. All I know is;

- It's one of the latest cards from last year (I dont have part number on hand).
- Nothing on the screen happens when I load the SD card. No error messages, zip, notta!
- I followed practically all the plug and play video directions on YouTube and still nothing.
- Even on the NAV screen it still just shows the compass and grid coordinates.
- The SD card is not in the locked position.

I'm not sure if I got a faulty card or if i have to do a firmware update (which I'm still clueless on how). Any suggestions would surely be appreciated from the community. Also, in case the card is bad the seller did message me back about returning it and exchanging if I have to go that route.
With Ebay, need to be careful who the seller is, is all, there are a few legitimate dealers selling cards without Markup, so read seller profile carefully too, another possibility is that instead of a US spec card, they snuck in one that was meant for another region.

Another route to take: If dealer kept your firmware updated (70.00.21 and above) consider installing the Android Auto/Apple Car Play retrofit kit instead. NNG will want $186 for a new 3 year subscription vs most places charging $150ish for the kit, (dealer wants a hefty labor fee of ~$350ish).

OR, if you're comfortable with DIY'ing it all, there's detailed instructions on what to do at the Mazda3 Revolution forum. (Firmware update procedure included)

https://mazda3revolution.com/forums/.../230249?page=1

Read the first three pages thoroughly before you decide to take this path.
mirage_i is offline  
post #5 of 17 (permalink) Old 05-17-2019, 11:31 PM Thread Starter
Learners License
 
crazy_raccoon's Avatar
 
Join Date: May 2019
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by b1lk1 View Post
If it came from China toss it in the bin.


Get it the proper way from a dealer and you won't have these issues. Before you cry about the price you already knew it was not gonna be cheap to upgrade or you did not do any homework before you bought the car.




Ebay is a royal shithole as of late, most likely you got taken.
It's not so bad really. The seller was real quick in helping solve the issue. I plan on sending it back and if this one fails too then I'll just get a refund. A few of my buddies in the past never had issues with their eBay NAV cars for the Mazda 6 or CX-5s they've owned. It didn't hurt because I only payed $50 for the card and the seller already sent me a free return label.
crazy_raccoon is offline  
The Following User Says Thank You to crazy_raccoon For This Useful Post:
b1lk1 (05-18-2019)
post #6 of 17 (permalink) Old 05-18-2019, 02:10 AM
Registered User
 
Brightshen's Avatar
 
Join Date: Dec 2018
Posts: 97
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Thanks: 2
Thanked 3 Times in 3 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
I got one from eBay and it worked perfect, as do my extra fobs. I'm not paying dealer price for things like that. Be careful, read feedback and eBay can be nice tool.
Brightshen is offline  
post #7 of 17 (permalink) Old 05-21-2019, 11:37 AM
Learners License
 
Join Date: Mar 2018
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Read ebay listings and feedback carefully as others have mentioned on this thread. You can also check out https://www.mazdapartsprime.com/ for everything OEM Mazda. I like buying from them because their prices are cheaper than dealer.
Skywalker1 is offline  
post #8 of 17 (permalink) Old 05-24-2019, 09:24 PM Thread Starter
Learners License
 
crazy_raccoon's Avatar
 
Join Date: May 2019
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
So I just got my replacement card from the same seller and that too does not load up. I'm not sure if it's because the card has 2018/2019 maps and possibly might require new firmware or something? My firmware is currently this on the vehicle;

OS Version 59.00.441 NA N
Music Database Version 00.07.000
Fail-Safe Version 59.00.441

The card I recieved is;

NA
BHP1 66 EZ1J

Is anyone or has anyone ever had this problem with the SD NAV cards for our vehicles? It seems odd that this plug n play navigation is not working. I just can't possibly think of anything that could keep the card from loading unless of course the card itself is bad. Do I have to upload maps or something because my interpretation is that it's already loaded onto the card and all you have to do is plug it in.
crazy_raccoon is offline  
post #9 of 17 (permalink) Old 05-25-2019, 12:03 AM
Registered User
 
Join Date: Jun 2014
Posts: 135
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 57 Post(s)
Thanks: 0
Thanked 19 Times in 16 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by crazy_raccoon View Post
So I just got my replacement card from the same seller and that too does not load up. I'm not sure if it's because the card has 2018/2019 maps and possibly might require new firmware or something? My firmware is currently this on the vehicle;

OS Version 59.00.441 NA N
Music Database Version 00.07.000
Fail-Safe Version 59.00.441

The card I recieved is;

NA
BHP1 66 EZ1J

Is anyone or has anyone ever had this problem with the SD NAV cards for our vehicles? It seems odd that this plug n play navigation is not working. I just can't possibly think of anything that could keep the card from loading unless of course the card itself is bad. Do I have to upload maps or something because my interpretation is that it's already loaded onto the card and all you have to do is plug it in.

You firmware might be too old. Have the dealer update it or you can update it yourself here: https://my.hidrive.com/share/hsodpqj...irmware/NA%20N


Bought a eBay card with the same part number and no issues on newer firmware.
guy989 is online now  
post #10 of 17 (permalink) Old 05-25-2019, 11:53 AM
Registered User
 
oblivioncth's Avatar
 
Join Date: Dec 2018
Posts: 57
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 9
Thanked 3 Times in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
At least read over how you'd update it yourself and concider it. It's really easy with the only risks being:

1) There are two files and you have to make sure you install them in the right order (not hard as long as you're paying attention lol)

2) There is a period of about 30 to 40 minutes that you can't shut your car orr but the engine won't be on, so if your battery is old you'd need to charge is before/after or possibly even replace it

I'm not sure how much the dealer charges for an update but I'm positive it's at the bare minimum $100 and not something I'd ever want to pay.
oblivioncth is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Safety Features -2014 Mazda 6 Atenza GJ Auto vs 2015 Mazda 6 Touring GJ Series 2 Auto Amarnadh Newbie Section 1 01-10-2019 08:22 PM
Genuine Mazda 3 Windshield Sunscreen. Years 2014-2017. (P/N: 0000-8M-L40) mazdaswagparts Mazda Swag 0 08-01-2018 01:45 PM
2016 Touring MT -- navigation card on Ebay gladesteen 3rd-Gen 3 01-02-2016 09:59 PM
Mazda 6 and Mazda 6 Parts Available WRW-Sydney Australia 4 04-18-2005 11:37 AM
6 engine BlackV6 Engine / Drivetrain 17 12-06-2003 10:00 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome