Rear Window Defroster Does Not Work - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-09-2007, 09:52 AM Thread Starter
Learners License
 
Join Date: Jul 2007
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Hello everyone,

I did a lot of search to see if there's a similar problem. I did not see anything. I have a 2004 6i and the defroster does not work. I just bought it several months ago and just realized one morning when I turned it on that it does not work at all. It did not clear the moisture condensation that built up the inside glass. No sign that the wires even heat up. The indicator turns on when I press the rear defogger button. I checked to see the fuse but I cant make out which fuse it uses. Does anyone know which one? Please let me know. I also checked the wires on the glass windshield to see any breaks. No breaks in the wire wires. I also checked the relay in the engine compartment with an ohmeter. That is working fine.

Also does anyone know where the electrical connector attaches to the wires on the glass. Is it under the rear deck or on the side? which side? I want to check that to see that there is no loose connection.

Please help. I would like to fix this before winter.
flippu10 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome