Blown Ballast - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-10-2007, 05:56 PM Thread Starter
Registered User
 
Egierda's Avatar
 
Join Date: Nov 2006
Location: Ontario
Posts: 2,729
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 54
Thanked 119 Times in 89 Posts
Groans: 3
Groaned at 27 Times in 21 Posts
iTrader: 0 reviews
Send a message via MSN to Egierda
soo,

NEVER buy a Maxcar HID kit! I noticed that my right low beam did not come on this morning and after hooking up another ballast to that side i was determined that it was in fact the ballast that had blown. i'm going to be making a warrantee claim as soon as i can but i'm not looking forward to installing another POS ballast again.

i only had this kit hooked up for about 2 weeks or so...

08 Toyota FJ Cruiser - CURRENT

04' 6s MTX sedan
- SOLD

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Egierda is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome