Broke Center Console Climate Control Circuit Board - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 01-15-2007, 11:43 AM Thread Starter
Registered User
 
silaszeus's Avatar
 
Join Date: Sep 2004
Location: O.C., SoCal
Posts: 91
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
While taking out the center console, I forgot to unscrew the two screws underneath the manual climate control knobs and broke the climate control circuit board behind it as I was pulling out the center console. Now, my AC/heat and the audio tuner knob (the one on the right) don't work.

How can I fix this? Think I can just superglue the board back together (it's in four pieces)? How can I get a replacement? Does anyone know how much it would cost? Or should I just go to a Mazda dealership and get the part and/or it serviced? I know my warranty will probably be voided cuz I screwed around and screwed up. Please help!

"Cockroaches, many perceive as evil,
But if you're from the projects, them ni&&as are like people!
They sleep with you, eat with you, listen to beef with you."
-- Necro, "Cockroaches"
silaszeus is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-15-2007, 04:09 PM
Registered User
 
dream weave's Avatar
 
Join Date: Jan 2005
Location: Greensburg, PA
Posts: 1,212
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
superglue won't work, you broke the electrical connections, you will need to replace the entire plastic piece. get in touch with either sabrina @jimclick or Tiffany at showcase mazda and they can get you a price quote, it will be less than thru your dealer.

no more 6
dream weave is offline  
post #3 of 4 (permalink) Old 01-15-2007, 06:42 PM
Registered User
 
bootsie's Avatar
 
Join Date: Apr 2005
Location: Farmington MN
Posts: 536
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I did the same thing except I forgot to unscrew the bolt fromt the glovebox, I had to search one out on ebay ended up getting one for like $50

2004 Lapis Blue 6I Sport Package
Current Mods
| Eibach Pros | AEM CAI | MagnaFlow Exhaust | Kartboy Hangers | 22% Tint all around | Autoexe Grill (being painted) | Eyelids (being painted) | Chrome Tails and smoked rear reflectors | VG Sharkfin | Mesh Grill and Bumper Inserts | Debadged | Shaved Door Moldings | Clear Side Markers with LED's | Parking Light LED's | Blue Lit Gauge Cluster and Console | Blue Interior LED's | MetraKit with Panasonic w/ Ipod Intergration | Hidden IPOD | 2 10" Treo Engineering TS Subs | Custom Fiberglass Enclosure


Future Mods ( this winter/spring )
| Rims and Tires or Leather Interior
bootsie is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 01-21-2007, 10:26 AM
acewrestler
Guest
 
Posts: n/a
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Quote:
I did the same thing except I forgot to unscrew the bolt fromt the glovebox, I had to search one out on ebay ended up getting one for like $50[/b]

I had the same type of problem yesterday. i didnt break anything, but when i reinstalled the HU, my rear defrost and audio tuning buttons stopped working. I have no clue what is wrong, so if anybody has an idea of what may be wrong please help. thank you.
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome