HID issue. - Page 3 - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

Reply
 
LinkBack Thread Tools
post #21 of 41 (permalink) Old 11-14-2005, 02:12 PM
Registered User
 
AzMz6's Avatar
 
Join Date: May 2004
Location: Phoenix, Arizona
Posts: 1,951
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to AzMz6 Send a message via MSN to AzMz6
both of mine were doing that flickering and then shuting off. so i sent a pm to rpm. allready got a new set coming to replace my ballasts.

btw- rpm is still one of the best sellers i have ever delt with. bar none. thanks guys.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

a 2003 SVT Mustang Cobra also is sitting in my garage....
AzMz6 is offline  
Sponsored Links
Advertisement
 
post #22 of 41 (permalink) Old 11-14-2005, 04:18 PM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
Quote:
Originally posted by sry110@Nov 14 2005, 02:53 PM
As I mentioned earlier, I have this same problem and after I contacted FalconTX he had a new ballast shipped to me.* I also purchased XTec's wiring harness, which bypasses the stock wiring with regards to power supply (i.e. hooks up directly to the battery, instead of drawing power through the stock headlight wiring).* The new ballast should take care of the problem, but in case it doesn't and I keep having to turn the headlights on/off/on again to get them both to stay on, I don't want to be cycling the power as such through the stock wiring.* I say this because the headlights draw a lot of power when they first turn on, then they run cooler than stock on a continuous basis.* The Xtec harness is beefy to say the least, because it is sized for the peak load during bulb ignition.

Anyway that's a little off the topic, and I haven't even done my re-install yet to replace the ballast and install the wiring harness, but I like the peace of mind that the directly-connected wiring harness will give me.
[snapback]557101[/snapback]
how much is the XTEC wiring?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
post #23 of 41 (permalink) Old 11-14-2005, 04:19 PM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
Quote:
Originally posted by AzMz6@Nov 14 2005, 03:12 PM
both of mine were doing that flickering and then shuting off. so i sent a pm to rpm. allready got a new set coming to replace my ballasts.

btw- rpm is still one of the best sellers i have ever delt with. bar none. thanks guys.
[snapback]557114[/snapback]
i got an email back from XenonDepot. seems like i have to send my ballast back and they exchange it out... ooh! i can't wait.

i wonder how long all of this takes


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
Sponsored Links
Advertisement
 
post #24 of 41 (permalink) Old 11-14-2005, 05:21 PM
Registered User
 
AzMz6's Avatar
 
Join Date: May 2004
Location: Phoenix, Arizona
Posts: 1,951
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to AzMz6 Send a message via MSN to AzMz6
i like what rpm does better... i only have to yank the bumper once for those things....


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

a 2003 SVT Mustang Cobra also is sitting in my garage....
AzMz6 is offline  
post #25 of 41 (permalink) Old 11-14-2005, 06:28 PM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
Quote:
Originally posted by AzMz6@Nov 14 2005, 06:21 PM
i like what rpm does better... i only have to yank the bumper once for those things....
[snapback]557283[/snapback]
what do you mean?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
post #26 of 41 (permalink) Old 11-15-2005, 12:05 AM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
for ya'll that got their ballasts exchanged... how long did it take you for you to receive the ballast?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
post #27 of 41 (permalink) Old 11-15-2005, 03:09 AM
Registered User
 
falcontx's Avatar
 
Join Date: Feb 2004
Location: Grand Prairie, Texas
Posts: 4,155
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 7
Thanked 14 Times in 14 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
To answer some of the questions...

All new kits are being shipped with new, known working ballasts. XtecUSA is going as far as testing each and every ballast shippped out for the time being.

We sell the optional Xtec complete wiring harness for $30 if it is shipped along with an HID kit, $35 if you purchased a kit from us in the past and want one shipped to you now, or $45 to anyone else.

With regards to exchanges, RPM offers an advance replacement program in which we take a reasonable deposit, ship the ballast(s) out quickly, and then refund the deposit once the bad ballast(s) are returned. When ballasts are ordered from us, they typically ship within a few days. I figured that most vendors offered this type of service, but since they obviously do not, we are willing to extend this program to any owner of an Xtec product, regardless of where it was originally purchased.

Are you one of our valued customers? Join The RPM Crew today and help spread the word! --
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Come check out our website! --
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-- We have a huge selection of parts for the Mazda 6 and Mazdaspeed 6!

Like us on Facebook for news and discounts! --
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
falcontx is offline  
post #28 of 41 (permalink) Old 11-15-2005, 12:07 PM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
i sent the deposit out to XenonDepot, and just waiting to get an ETA on it.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
post #29 of 41 (permalink) Old 11-19-2005, 08:34 PM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
hmm... i have had no response from XenonDepot on my status of my ballast replacement...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
post #30 of 41 (permalink) Old 11-21-2005, 05:37 PM Thread Starter
Registered User
 
zxc1104's Avatar
 
Join Date: May 2005
Location: michigan
Posts: 1,479
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to zxc1104 Send a message via MSN to zxc1104 Send a message via Yahoo to zxc1104
i emailed them, and i still haven't received any sort of update on my ballast status...

how long did it take you to receive your exchange?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zxc1104 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome