I failed my NYS inspection today - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 05-09-2005, 03:56 PM Thread Starter
Registered User
 
first mazda's Avatar
 
Join Date: May 2003
Posts: 1,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
As the title says, the last thing they do (at least for me) before passing you for inspection is to hook up to the OBD and get a report (something to do with emissions, I think). Well, they tried two different scanners at the original inspection place in addition to the main computer and there was no communication.

On the way back, I stopped over at another garage - a friend of a friend's - and they had the same problem. Per both places, the CEL DOES work. It comes on when the car is initially turned on (when all the lights do - I haven't actually thrown a CEL). They also checked all the fuses.

That's why I'm asking about any relationship with the foglight mod. I know it's out there but they kept asking me if I was SURE I hadn't done anything with the car. I didn't tell them about the wire cutting but... everything works fine. The foglight mod from the other thread is just a little wire re-routing but I can't see how that would affect the communication of the OBD. Anyway, I'm sitting there watching them poke and prod around the fuse box like "Oh shit...".

I can't get into the dealership until next Wed. Until then, I'm uninspected... one less ugly sticker ont he car - yay!
first mazda is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-09-2005, 04:05 PM
Registered User
 
blackmagik_13's Avatar
 
Join Date: Jan 2004
Location: Orlando, FL
Posts: 5,129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 13 Times in 5 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Send a message via AIM to blackmagik_13 Send a message via MSN to blackmagik_13 Send a message via Yahoo to blackmagik_13
What wiring did you have to 're-route' and cut? And I take it your drawing power from the fusebox since you were thinking 'Oh shit..." whenever they were inspecting it? Need more info...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
blackmagik_13 is offline  
post #3 of 10 (permalink) Old 05-09-2005, 04:25 PM
Registered User
 
CvilleSix's Avatar
 
Join Date: Mar 2003
Location: Baltimore, MD
Posts: 1,885
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Just to ask the stupid question, are you sure these places had *CANbus-capable* OBDII scanners?

2003 Performance White 6i Sedan, MTX Used to have a turbo, now pursuing the DD dream


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CvilleSix is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 05-09-2005, 04:28 PM
Registered User
 
blackmagik_13's Avatar
 
Join Date: Jan 2004
Location: Orlando, FL
Posts: 5,129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 13 Times in 5 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Send a message via AIM to blackmagik_13 Send a message via MSN to blackmagik_13 Send a message via Yahoo to blackmagik_13
^ I was wondering the same thing when I 1st read it but I thought that was a given....

If you go to Auto Zone and they use their little cheapy scanner, it'll say "No Communication" or something along those lines as well.

Make sure they're running the proper scan tools. Must be OBD-II CAN Compatible. *did you expect any less, Mazda has to make it hard on us *


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
blackmagik_13 is offline  
post #5 of 10 (permalink) Old 05-09-2005, 07:50 PM Thread Starter
Registered User
 
first mazda's Avatar
 
Join Date: May 2003
Posts: 1,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Well I freakin' thought they would know to use the correct instrument. Damn. I'm gonna have to call tomorrow and verify. I was planning on stopping by AutoZone on the way home but after getting the second diagnosis (or lack there-of) I thought it'd be a waste of time.

Maybe I'll stop in tomorrow and make sure they use a CAN capable one. Regardless, for NYS inspection they have to use the computer specified by NYS DMV. It's not a standalone scanner, per se. Since they use that computer for every inspection, it *should be capable...
first mazda is offline  
post #6 of 10 (permalink) Old 05-09-2005, 08:05 PM
Registered User
 
CvilleSix's Avatar
 
Join Date: Mar 2003
Location: Baltimore, MD
Posts: 1,885
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Quote:
Originally posted by first mazda@May 9 2005, 08:50 PM
Since they use that computer for every inspection, it *should be capable...
[snapback]407810[/snapback]
I agree, and that's why I called it the "stupid" question, but I've heard stranger things about NY state. (Maybe there's a grace period to upgrade to a new scanner, and/or they don't get many newer cars at that shop, etc, who knows?)

2003 Performance White 6i Sedan, MTX Used to have a turbo, now pursuing the DD dream


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
CvilleSix is offline  
post #7 of 10 (permalink) Old 05-11-2005, 11:18 AM Thread Starter
Registered User
 
first mazda's Avatar
 
Join Date: May 2003
Posts: 1,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Well, I didn't realize that this problem just came up for someone else...
http://forum.mazda6club.com/index.ph...ST&f=2&t=33129

I called around like crazy today to everyone I could think of... Pep Boys, Auto Zone, Advanced Auto to see if they had a CAN compliant scanner, and no one does. So I'm shit out of luck in trying to do a simple test.

I ended up calling the NYS DMV and spoke to someone specifically about the CAN compliance and the possibility that the garages could have been using an outdated computer. He told me that NYS requires everyone who does inpections to have the same software and equipment - and that it's CAN compliant. It's something they did to keep everything uniform for regulations or something like that.

So basically he said the computer *should have worked. If not, there's probably an issue with my car. Great. He also looked for anything about issues with the Mazda 6 and nothing like that came up, just some stuff about various false codes.

I wonder WTF is wrong with my carputer.
first mazda is offline  
post #8 of 10 (permalink) Old 05-11-2005, 11:59 AM
Mazda Guru
 
Join Date: Dec 2002
Location: Dracut, MA
Posts: 3,392
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 2 Times in 2 Posts
iTrader: 0 reviews
Send a message via AIM to GreenNuggs
Do you live next to a club member with one of the OBDII scanners? I would meet up with them and see what happens. I'd help you out, but I'm in eastern MA.

This reminds me. My sticker is due this month. I hope I don't fail for the VAD pending code.
GreenNuggs is offline  
post #9 of 10 (permalink) Old 05-11-2005, 12:50 PM
Registered User
 
docgoku's Avatar
 
Join Date: Apr 2004
Location: Greenwood, SC
Posts: 389
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via MSN to docgoku
I had the same type of problem here in Atlanta when my 2000 Volvo S70 first came up for inspection in 2002/03. Something about the Volvo OBDII system was slightly different than all others and they couldn't get any type of connection with their scanners. Eventually I had to call the emmisions office and they informed me that the scanner software for emmisons hadn't been updated to be compatiable with my Volvo! So they gave me a waiver for the next year b/c everything else had checked out just fine.

I'd verfiy the machine works b/c in GA you have 2 years after the car is new where inspections aren't needed but once you do need them the tools used may not have your car's specs loaded yet!

JH
SOLD - 04 Mazda 6s SportWagon - Glacier Silver - 5M

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
docgoku is offline  
post #10 of 10 (permalink) Old 05-11-2005, 03:21 PM Thread Starter
Registered User
 
first mazda's Avatar
 
Join Date: May 2003
Posts: 1,168
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Well I was talking about the issue at work today and the boss, aka my brother in law, said to try out his guy, someone who own's a Mobil Station/ repair/ inspection joint. I called and explained the problem, and asked if he had CAN compliant scanners. When he said he did I arranged to stop by just to hookup and see if he could get any communication. The results were good and bad. He told me 2:15 "on the dot"... I got there at 2:13 and waited till about 2:45 until his tech came back from lunch. That's fine... but as they start to investigate my car I see that the door being open will hit a large hard plastic drum on it's edge if opened too far. They say don't worry as they only open it so far. Unfortunately, as they each try their turns at plugging and unplugging the fuck out of my com port, they keep hitting the drum until the door makes it PAST where it should have gone. My heart stopped as I was forbidden to enter the bay and could only helplessly watch from about 10 ft away. I come to figure that the tech's weight inside the car pushes it down enough for the door to clear where it would catch, but I sitll give a hesitant "could you please be careful as you get out because when your weight is off the car, it's gonna catch that drum". The response? "This one? It's plastic".

Well, after about 10 minutes of playing with the Snap On handhled scanner, they get communication. As they are about to pull out, they ask if I just want them to finish off the inspection since my paperwork already shows I passed the safety part. I ask how much, and they say the state prints the charge... another $11 on top of the $21 I already paid. Between another $11 and the possibility of getting pulled over in the next week until I get to the dealership or even the possibility that returning to the original garage will result in another communication failure and ANOTHER inspection "F", I took the deal. It took them another 15 frikking minutes of plugging and unplugging, starting and re-starting before they finally got approval. They said there's definitely something screwy going on.

What a f'ing PITA. Good side - I am 100% inspected. Bad side - two inches of the edge of my door is now clearcoat free. My car and I will forever be scarred by state inspections. ... and I STILL have to keep my appointment with the dealer to see if there is, indeed, something wrong with my ports.
first mazda is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome