Fuse Help needed - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 04-12-2005, 06:44 PM Thread Starter
Registered User
 
yepandIluvit's Avatar
 
Join Date: Jun 2004
Location: newark,DE
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to yepandIluvit
Hello, i installed some LEDs, what i did to install them was run + and - wires straight from the battery to a switch and then ran wires from the switch to each light, the lights are meant to recieve power straight from the battery, everything works great but for safetys sake i want to run a fuse on the wires before they get to the switch so i don't go screwing up my 6....anyone have any idea what type of fuse i would need? originally i tried getting the power from a 15 fuse used for the radio but kept blowing it so i simply hooked it up straight to the battery. the switch has a 20amp max and once again everything WORKS! I just want to know what type of fuse to put inbetween the battery and the switch. thanks
yepandIluvit is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome