DIY: Installing 3rd Gen Switchback - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 1Likes
  • 1 Post By Leaky
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 03-23-2015, 12:48 AM Thread Starter
Registered User
 
Join Date: Feb 2015
Posts: 73
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 0
Thanked 12 Times in 9 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
DIY: Installing 3rd Gen Switchback

Okay....so I spent a bit of time researching and figuring out how to complete the front running light/turn signal "switchback" LED bulb transfer. Gotta say VERY happy with the results. Although I know that there are plenty of suggestions and locations where to get your replacement LEDs, I got mine from ijdmtoy.com. They are local to me here in So Cal, have great selections, and are VERY helpful with selection as well as installation. Here is the link to the bulbs I ordered:

60-SMD 7440 Single Filament Switchback LED Bulbs For Turn Signal

Since I ordered numerous other bulbs, ijdmtoy evidently was generous and actually INCLUDED two 6 ohm resistors with my order. That was way cool.

As they had a "mysterious" extra wire protruding from the base, I called up ijdmtoy to inquire. What I found out was I was just ignorant and did not look at the "installation instructions" that were on the page where the bulbs were located. Bottom line, once I read over that, I figured I was ready to tackle the job. Looking at the owner's manual, I saw that to replace the signal lights you need to go in through the wheel well. Knowing I had to do some wiring, I elected to pull the front wheel to allow easy access. I jacked the nose up and looked it all over, and determined that I needed to get the whole front portion of the inner lining loose. That was easy for almost all of it; the simple little plastic snap clips came out simply. However, to really gain easy access, I needed to get access to one phillips screw that was actually underneath the nose pan fairing. I have included a couple pictures of what I am describing. I took one screw and one plastic clip off of the nose pan, and then took a screwdriver and removed the one screw. That allowed the whole inner fenderwell plastic to drop free. The first picture shows the front pan that needs to be unscrewed. The second shows the bolt that needs to be removed. Although almost impossible to see, the next shows a phillips screwdriver inserted to the screw needed to remove the rest of the liner. Once that was done, the entire fender liner can be pulled down and free (photo 4). Once all was free it was easy to look in and pull the stock bulb from its socket. At this point it was time to figure out how to wire things up. I cut the black outer lining back a bit to allow easier acces to the wires (photo 5). I then stripped a small portion of each wire (photo 6). I will save you the details; just suffice it to say that the "spare" small red wire coming out of the socket of the bulb needs to be spliced into the GREEN wire of the socket, and the resistor needs to be tapped from one red wire into the other. Prior to doing any final wiring, I looked into mounting the resistors. As a safeguard, I soldered pigtails onto the ends of the resistors to ensure there was sufficient lead length (photo 7). Looking at mounting potential, I saw that there was an open structural member running from the outer fender to the inner engine bay with nothing really attached (photos 8 and 9, LH and RH respectively). I marked the holes with a sharpie, drilled the holes, and then mounted the resistors with some surplus small sheet metal screws (photo 10).I then wrapped all of the wires together, then soldered and taped them over after checking to ensure everything worked. As I have evidently exceeded my limit here, I will finish up in a follow up installation.
Attached Thumbnails
Click image for larger version

Name:	image(1).jpg
Views:	165
Size:	199.3 KB
ID:	145225   Click image for larger version

Name:	image(2).jpg
Views:	186
Size:	219.1 KB
ID:	145233   Click image for larger version

Name:	underside tray.jpg
Views:	148
Size:	168.8 KB
ID:	145241   Click image for larger version

Name:	rh liner loose.jpg
Views:	153
Size:	176.3 KB
ID:	145281   Click image for larger version

Name:	sleeve cut back.jpg
Views:	161
Size:	177.0 KB
ID:	145313  

Click image for larger version

Name:	wires stripped.jpg
Views:	147
Size:	174.3 KB
ID:	145329   Click image for larger version

Name:	resistors.JPG
Views:	154
Size:	314.5 KB
ID:	145337   Click image for larger version

Name:	lh mounting marks.jpg
Views:	141
Size:	175.2 KB
ID:	145345   Click image for larger version

Name:	locating resistor.jpg
Views:	127
Size:	210.5 KB
ID:	145353   Click image for larger version

Name:	resistor mounted.jpg
Views:	128
Size:	143.4 KB
ID:	145361  

danstheman7 likes this.
Leaky is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-23-2015, 01:02 AM Thread Starter
Registered User
 
Join Date: Feb 2015
Posts: 73
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 0
Thanked 12 Times in 9 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Once all was soldered, taped up, and mounted, all that was left was to insert the new bulb into the receptacle, and that into the socket. The bulbs went in pretty tough, but with enough pressure, they locked in nicely. Once done, I VERY carefully inserted the assembly into the socket, making sure there was sufficient slack in the thin red wire to not cut it when I locked it into place.

Once everything was done and checked, I simply buttoned everything back up again. I am VERY happy with the results. I have included a few pics, although with a poor camera it doesn't do justice.
Attached Thumbnails
Click image for larger version

Name:	ready to install.jpg
Views:	137
Size:	156.3 KB
ID:	145377   Click image for larger version

Name:	running lighht 1.JPG
Views:	156
Size:	145.0 KB
ID:	145385   Click image for larger version

Name:	running light 2.JPG
Views:	145
Size:	196.6 KB
ID:	145393   Click image for larger version

Name:	turn signal.JPG
Views:	157
Size:	223.4 KB
ID:	145401  
Leaky is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome