front right turn signal - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 9 (permalink) Old 05-20-2004, 12:31 PM Thread Starter
Learners License
 
Join Date: Dec 2003
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
front right turn signal

ok guys i picked up ma 2004 lapis blue mazda 6s 5speed last monday...i friggin love the car~!!.....got about 730 miles on in right now but i noticed that somes times my right turn signal in the head light assembly doesnt work at all and sometimes it does......could it be a loose wire?....i checked the wire seemes pretty tight ......some help please....thanx a lot
sukhyunx012 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 05-21-2004, 10:31 AM
Registered User
 
Join Date: Mar 2004
Posts: 275
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Replying to Topic 'front right turn signal'

Move to Texas and quit using your turn signals. Problem solved. :D

Seriously, if the problem is isolated to a single front lamp, the odds are it is a loose connection. If the problem affects the front and back on that side, add a suspect turn signal switch to your list. If it problem affects both sides of the car, add a suspect relay to the list of possible causes.

Does it act up frequently enough to reproduce it at the dealership? If so, save yourself the heartache and let them troubleshoot it for you.
Monk is offline  
post #3 of 9 (permalink) Old 05-22-2004, 04:55 PM
Learners License
 
Join Date: May 2004
Location: White House, TN USA
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Replying to Topic 'front right turn signal'

I had the same problem except it was the left front. One of the sales managers fiddled with the connection and it started working fine. that was abot 2500 miles ago and it just started doing it again
linzTNstlgrey is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 05-23-2004, 12:14 AM
Learners License
 
Join Date: Feb 2004
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Replying to Topic 'front right turn signal'

I just had this problem last week. I searched the forums and it seems to be happening to several people. I haven't taken my car in yet, but here is the link to the forum which states that mazda has a particular solution:
https://www.mazda6club.com/forums/read.php?TID=11435
stix16 is offline  
post #5 of 9 (permalink) Old 06-04-2004, 09:28 AM
Registered User
 
04WhiteSix's Avatar
 
Join Date: Apr 2004
Location: Illinois
Posts: 313
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Reading Topic: front right turn signal

what you do is take out the turn signal (turn hard! until it clicks then pull it out) take a look at the silver contacts in the middle of the unit and bend them out a bit then put back in and perfecto!

2004 Mazda 6S MTX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 Yamaha Warrior
04WhiteSix is offline  
post #6 of 9 (permalink) Old 06-04-2004, 03:23 PM
Registered User
 
mbrogz3000's Avatar
 
Join Date: Jul 2003
Location: Northern NJ
Posts: 1,775
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 25 Times in 3 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Replying to Topic 'front right turn signal'

Quote:
Originally posted by 04WhiteSix


* * * * * * what you do is take out the turn signal (turn hard! until it clicks then pull it out) *take a look at the silver contacts in the middle of the unit and bend them out a bit then put back in and perfecto!
yeah, do this AND rub down the contact with rubbing alcohol...also look for fingerprints...mine had a fingerprint from the factory
mbrogz3000 is offline  
post #7 of 9 (permalink) Old 06-10-2004, 04:07 PM
Learners License
 
Join Date: Jun 2004
Location: Minneapolis, MN
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Replying to Topic 'front right turn signal'

Quote:
what you do is take out the turn signal (turn hard! until it clicks then pull it out) take a look at the silver contacts in the middle of the unit and bend them out a bit then put back in and perfecto!
To emphasize this point, same happened to me before I even pulled out of the dealership. According to their mazda tech, they desined this new gig with the bulb attached to a plastic shaft for easier access. You won't get a ground signal unless you turn it clockwise untill it click. My fix took seconds.
jpmm is offline  
post #8 of 9 (permalink) Old 06-14-2004, 08:34 AM Thread Starter
Learners License
 
Join Date: Dec 2003
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Reading Topic: front right turn signal

thanx alot for ur help guys....problem fixed....=)
sukhyunx012 is offline  
post #9 of 9 (permalink) Old 07-06-2016, 12:57 PM
Learners License
 
Join Date: Sep 2014
Posts: 5
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I know this is an old thread but I'm hoping that someone is still paying attention. I've got a 2004 Mazda 6 sedan that would occasionally have issues with the left turn signal not blinking. When pushing down the left turn signal switch, the signals would stay off. I could have it engage by manually turning the switch up and down, but in the last few days even that doesn't work. Here's what I've done:

1) Changed front and back turn signal bulbs.
2) Checked the front turn signal socket, pulling out the silver contacts to ensure they're making contact.
3) Tried the right front turn signal socket in place of the left socket.
4) Checked the fuse.

No luck with any of these steps. Any ideas?
FrostyOfTheNorth is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome