Very strange problem - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-21-2019, 07:30 PM Thread Starter
Learners License
 
BeachGirlNJ's Avatar
 
Join Date: Jan 2013
Location: Bayville, NJ
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 7
Thanked 2 Times in 2 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Question Very strange problem

This has happened twice recently. When I lower the passenger visor, and pull it to the left to screen that middle space -- I bumped that black "box" behind the rear view mirror. Both times the audio immediately stopped, the dash display went blank, and the fob no longer worked. It's the most bizarre thing. First time it happened my husband checked all the fuses and found and replaced one that apparently controls a bunch of different things, and that fixed it. It just happened again and, yeah, he'll replace the fuse again. [Going forward I'll be careful not to hit that damn box again. ] My question is: what the heck is in that box that a light bump knocks out all that stuff?! I never thought it contained anything so I'm baffled.

Cindi
"Blue Belle" ~ 2009 Mazda 6i Touring
BeachGirlNJ is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-21-2019, 08:36 PM
Registered User
 
michaelsteinbach's Avatar
 
Join Date: Sep 2008
Location: Carbondale, IL
Posts: 895
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 5
Thanked 63 Times in 51 Posts
Groans: 3
Groaned at 1 Time in 1 Post
Garage
iTrader: 0 reviews
I think it's just the rain sensor and wiring for your mirror.
The box is split down the middle and can be removed by pulling each half to either side. There's probably a frayed wire.

~Mike

2009 Mazda 6 GT in Sangria Red.
michaelsteinbach is online now  
post #3 of 3 (permalink) Old 06-21-2019, 08:39 PM
Registered User
 
dcoulombe's Avatar
 
Join Date: Jan 2012
Location: QC, Canada
Posts: 163
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Thanks: 53
Thanked 17 Times in 14 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Very strange problem

Trying to answer from memory as I don't have a 2nd gen anymore. There's a bunch of electronic in there for the rain sensing wipers and auto dimming rear view mirror. Maybe there's a short in the wiring? Has the windshield been replaced?

Edit: Mike beat me to it.


Sent from my iPhone using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dcoulombe is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome