Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum - View Single Post - Chris' 2007 Mazda 6s Hatch
View Single Post
post #166 of (permalink) Old 06-11-2019, 05:27 AM Thread Starter
bluedevil6
Registered User
 
bluedevil6's Avatar
 
Join Date: Nov 2017
Location: Canal Fulton Ohio
Posts: 599
Mentioned: 59 Post(s)
Tagged: 1 Thread(s)
Quoted: 208 Post(s)
Thanks: 33
Thanked 35 Times in 33 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
Without too many spoilers about what is happening right now, and believe me it a lot more than just the frame, I wanted to share with all of you the full extent of my frame rot.
In the photo the welds (red) for the rack mounting point were also broken halfway across I pulled that side of the sway bar off without even unbolting it!



Sent from my iPhone using Tapatalk

2007 6 Hatch 3.0 V6 ATX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mods tinted windows, trans cooler, triple gauge dash pod, EGR tube delete, TB coolant bypass, gutted exhaust w/ MagnaFlow muffler
To Come lowering springs, sway bars, subframe brace, strut tower brace
Places to find me-
->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<-


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bluedevil6 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome