Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum - View Single Post - 2005 Mazda 6 wagon
View Single Post
post #8 of (permalink) Old 01-29-2019, 02:50 PM Thread Starter
Jael Ryan
Learners License
 
Join Date: Jan 2019
Posts: 23
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Quote:
Originally Posted by DrFeelGood View Post
Quote:
Originally Posted by Jael Ryan View Post
Hi I'm new in this forum. My car is throwing a lot of codes involving the EGR and the system Bank. I have a po303 po401 p2179 p2177 and many more does anyone know how to diagnose this or fix it?

Welcome to the form, we love our wagons (although I could be biased)


The P0303 is the killer, you gotta get this fixed. Usually I is remedies by new plugs and coils but moving cylinder 3 to another location and waiting for the code retuen would be a way to verify. (It is happened so many times on this forum that if you haven't replaced those items I would just do all 6)


The search bar in the upper right will take you straight to all those codes. There you can read what other people did to fix similar scenarios.


If I had to guess I would say either the EGR is clogged or the EGR purge valve solenoid is not working.
For the Lean codes make sure you do net have an intake air leak. The accordion hose running from the air cleaner is notorious.


OEM parts
Mazda AJTT-18-110 - Spark Plugs x6 (these will be Motorcraft AGSF 22FSCM)
DENSO 673 6005 - Ignition Coils x6
I checked the accordion hose and found no leak thus far with my miniscule car know how. My dad suggested taking it to Mazda for diagnostics and see what it'll need.
Crossing fingers it won't take all my tax money
Jael Ryan is offline  
 
 
For the best viewing experience please update your browser to Google Chrome