Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum - View Single Post - 3rd gear doesn't seem to do much
View Single Post
post #2 of (permalink) Old 06-23-2018, 01:23 AM
DrFeelGood
Rally Racer
 
DrFeelGood's Avatar
 
Join Date: Aug 2013
Location: Portland, OR
Posts: 1,561
Mentioned: 171 Post(s)
Tagged: 3 Thread(s)
Quoted: 445 Post(s)
Thanks: 123
Thanked 171 Times in 160 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
Garage
Quote:
Originally Posted by SubtleIceCream View Post
Bit of a car noob so bear with me. First of all I have a 2008 6i, 2.3L. 3rd gear I noticed is not as powerful as it usually is. It feels sorta like if I were in 5th gear but only going like 25mph. I thought it may be a fluid issue so I did a transmission fluid and filter change today, but the problem persists (although shift shock is a thing of the past.) So I turn to my own thread instead of searching through ones that kinda match but not really. I can probably provide any information you might need, thanks in advance to anyone who even thinks about my issue.

P.s. no codes except the stat is stuck open. That's for a different day.

Have you replaced your trans fluid?

Drain and refill 3x seems to be a good way to go.
Use only recommended fluid, do it warm and cycle the gears before each drain.


3rd gear gets a lot of work and I suppose It would wear out before the rest but I'm no transmission expert.


I would gamble the $120 in the hopes of saving the transmission.


Good luck!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mozz-D
2004 6s Wagon 3.0, 5-speed ATX
DrFeelGood is online now  
 
 
For the best viewing experience please update your browser to Google Chrome