Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum - View Single Post - I Need Help - Electrical issues after fender bender
View Single Post
post #1 of (permalink) Old 06-10-2014, 10:56 AM Thread Starter
Todesengel
Learners License
 
Join Date: Jun 2014
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
I Need Help - Electrical issues after fender bender

Hey guys,

My girlfriend got involved in a 3 car accident, she was the middle car. Nothing major, rear just needs a new bumper and paint. Front needed a new hood, passenger headlight, Radiator Support, and Radiator.

The car sat for about a month, while I waited for all the parts to arrive. I got the new parts installed, got the car back on the road and then suddenly it started jerking at above 50mph.

I have narrowed the issue down to 3rd and 4th gear of the automatic transmission. 1st and 2nd are fine, but when you get to 3rd it keeps slipping into neutral and back. Same with fourth.

I did the poor mans transmission flush, through the transmission cooler lines and refilled it with 8 quarts of mobile one transmission fluid and I also replace the transmission filter. Still having the same issue.

After about an hour of driving, it finally threw these codes.

p2507 - PCM Battery Voltage Low
p0767 - Shift Solenoid 'D' Performance (stuck on)

I assume these two are related? I had the battery and alternator tested at Auto Zone and they tested good. Multi-meter shows 12.97v at idle, and 14v at 2k RPM tested at battery.

I have searched the engine compartment high and low, and I cannot find any wiring issues. Is there something I can test, anything else to check?
Todesengel is offline  
 
 
For the best viewing experience please update your browser to Google Chrome