BSM not working - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 04-12-2016, 11:41 AM Thread Starter
Learners License
 
Join Date: Feb 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
BSM not working

The blind spot monitoring on my 2009 3.7L V6 (89,000 miles) has stopped working properly. Occasionally the light on the drivers side mirror will flash and I even heard the beep go off once without the light, but in no way is it working as it should .

I had heard if the bumper was dirty , that might affect operation, but that does not seem to be the cause here. There is also no obvious physical damage to those areas.

Has anyone had an issue with their BSM? I know the parts alone are $500 for each side so it sounds like it would be an expensive job if the sensors had to be replaced.
Mrshow000 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-12-2016, 12:57 PM
Registered User
 
michael95350's Avatar
 
Join Date: Jun 2015
Location: Modesto CA
Posts: 996
Mentioned: 16 Post(s)
Tagged: 0 Thread(s)
Quoted: 320 Post(s)
Thanks: 11
Thanked 80 Times in 73 Posts
Groans: 3
Groaned at 3 Times in 3 Posts
Garage
iTrader: 0 reviews
I think the BSM sensor is actually mounted on the upper half of the backglass. The bumper is usually for rear crash avoidance.
michael95350 is offline  
post #3 of 3 (permalink) Old 05-09-2016, 05:39 PM
Registered User
 
Join Date: Feb 2007
Posts: 86
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I had to replace one of the mirrors internals a few years back. Mine would work intermittently and malfunction until reset by turning off the car. Its been fine ever sense.
JeepRubicon2k3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome