2005 Mazda 6 wagon - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 6Likes
Reply
 
LinkBack Thread Tools
post #1 of 22 (permalink) Old 01-26-2019, 02:14 PM Thread Starter
Learners License
 
Jael Ryan's Avatar
 
Join Date: Jan 2019
Posts: 30
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
2005 Mazda 6 wagon

Hi I'm new in this forum. My car is throwing a lot of codes involving the EGR and the system Bank. I have a po303 po401 p2179 p2177 and many more does anyone know how to diagnose this or fix it?

Regards,
Jael Ryan
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jael Ryan is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 01-27-2019, 05:13 PM
Registered User
 
bluedevil6's Avatar
 
Join Date: Nov 2017
Location: Canal Fulton Ohio
Posts: 595
Mentioned: 59 Post(s)
Tagged: 1 Thread(s)
Quoted: 205 Post(s)
Thanks: 32
Thanked 35 Times in 33 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by Jael Ryan View Post
Hi I'm new in this forum. My car is throwing a lot of codes involving the EGR and the system Bank. I have a po303 po401 p2179 p2177 and many more does anyone know how to diagnose this or fix it?
Here are some snaps from my FSM hopefully these will help you. that P0303 is a misfire code and you are going to want to take care of that immediately so it doesn't destroy your pre-cats. I also noticed that your other codes could be caused by a misfire, my guess is that you need one or more new ignition coils they regularly go bad on these.
Attached Thumbnails
Click image for larger version

Name:	misfire code 303.jpg
Views:	49
Size:	142.0 KB
ID:	226148   Click image for larger version

Name:	p1 mf.jpg
Views:	46
Size:	142.0 KB
ID:	226150   Click image for larger version

Name:	p2 mf.jpg
Views:	48
Size:	156.0 KB
ID:	226152   Click image for larger version

Name:	p3 mf.jpg
Views:	26
Size:	142.7 KB
ID:	226154   Click image for larger version

Name:	p4 mf.jpg
Views:	26
Size:	124.8 KB
ID:	226156  

Click image for larger version

Name:	p5 mf.jpg
Views:	25
Size:	118.1 KB
ID:	226158   Click image for larger version

Name:	sys lean.jpg
Views:	28
Size:	174.7 KB
ID:	226160   Click image for larger version

Name:	p1 2177.jpg
Views:	27
Size:	124.6 KB
ID:	226162   Click image for larger version

Name:	p2 2177.jpg
Views:	26
Size:	160.8 KB
ID:	226164   Click image for larger version

Name:	p3 2177.jpg
Views:	28
Size:	156.6 KB
ID:	226166  

Kalalicious likes this.

2007 6 Hatch 3.0 V6 ATX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mods tinted windows, trans cooler, triple gauge dash pod, EGR tube delete, TB coolant bypass, gutted exhaust w/ MagnaFlow muffler
To Come lowering springs, sway bars, subframe brace, strut tower brace
Places to find me-
->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<-


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bluedevil6 is offline  
post #3 of 22 (permalink) Old 01-27-2019, 05:14 PM
Registered User
 
bluedevil6's Avatar
 
Join Date: Nov 2017
Location: Canal Fulton Ohio
Posts: 595
Mentioned: 59 Post(s)
Tagged: 1 Thread(s)
Quoted: 205 Post(s)
Thanks: 32
Thanked 35 Times in 33 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
here are the other pages, it would only let me attach so many at once lol
Attached Thumbnails
Click image for larger version

Name:	p4 2177.jpg
Views:	22
Size:	169.5 KB
ID:	226168   Click image for larger version

Name:	p5 2177.jpg
Views:	21
Size:	121.8 KB
ID:	226170  

2007 6 Hatch 3.0 V6 ATX

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mods tinted windows, trans cooler, triple gauge dash pod, EGR tube delete, TB coolant bypass, gutted exhaust w/ MagnaFlow muffler
To Come lowering springs, sway bars, subframe brace, strut tower brace
Places to find me-
->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- ->
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<-


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bluedevil6 is offline  
Sponsored Links
Advertisement
 
post #4 of 22 (permalink) Old 01-27-2019, 07:35 PM
Registered User
 
waughoo's Avatar
 
Join Date: Jan 2016
Location: Edmonds, WA
Posts: 1,803
Mentioned: 92 Post(s)
Tagged: 1 Thread(s)
Quoted: 422 Post(s)
Thanks: 7
Thanked 115 Times in 110 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Garage
iTrader: 0 reviews
@Jael Ryan , as @bluedevil6 says, solve those misfires pronto! I'm not sure how many miles you have on your long top, but the coils are a bit of a service item on these cars. It is unfortunate, but it seems that many people seem to start having issues at 100k miles. I would strongly suggest a full replacement of the coils and likely a set of plugs. The issue is that getting to them can be a bit of a problem and delaying the repair can cause significant expense and possible engine failure. I don't want to scare you there, but pre cat failure on these duratec v6 engines is well documented. I'd start with the misfire fix first. One thing I'd add too is that the harness clips that go into the coils can sometimes lose their pliability and they will break off the little clip that secures them into the coil. I had this problem and ended up using a small zip tie to make sure it would stay in place. It is not my favorite solution, but the only other resolution is to replace the plug at that given coil. I had bought the parts to do so but decided it was going to be so much work as there isn't much room to work on the harness at the coil location. I still have the clips but my zip tie solution is still working fine for the moment.
Kalalicious likes this.

Alex
2004 6s Wagon MTX - grocery hauler
---}
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
{---

MODS: Tinted windows, RX8s with 225/45 R18s,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
waughoo is offline  
post #5 of 22 (permalink) Old 01-27-2019, 07:43 PM
Rally Racer
 
DrFeelGood's Avatar
 
Join Date: Aug 2013
Location: Portland, OR
Posts: 1,520
Mentioned: 167 Post(s)
Tagged: 3 Thread(s)
Quoted: 432 Post(s)
Thanks: 121
Thanked 167 Times in 156 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by Jael Ryan View Post
Hi I'm new in this forum. My car is throwing a lot of codes involving the EGR and the system Bank. I have a po303 po401 p2179 p2177 and many more does anyone know how to diagnose this or fix it?

Welcome to the form, we love our wagons (although I could be biased)


The P0303 is the killer, you gotta get this fixed. Usually I is remedies by new plugs and coils but moving cylinder 3 to another location and waiting for the code retuen would be a way to verify. (It is happened so many times on this forum that if you haven't replaced those items I would just do all 6)


The search bar in the upper right will take you straight to all those codes. There you can read what other people did to fix similar scenarios.


If I had to guess I would say either the EGR is clogged or the EGR purge valve solenoid is not working.
For the Lean codes make sure you do net have an intake air leak. The accordion hose running from the air cleaner is notorious.


OEM parts
Mazda AJTT-18-110 - Spark Plugs x6 (these will be Motorcraft AGSF 22FSCM)
DENSO 673 6005 - Ignition Coils x6


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mozz-D
2004 6s Wagon 3.0, 5-speed ATX
DrFeelGood is online now  
post #6 of 22 (permalink) Old 01-29-2019, 02:44 PM Thread Starter
Learners License
 
Jael Ryan's Avatar
 
Join Date: Jan 2019
Posts: 30
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by bluedevil6 View Post
here are the other pages, it would only let me attach so many at once lol
Really appreciate this man&#x270a;
bluedevil6 likes this.

Regards,
Jael Ryan
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jael Ryan is offline  
post #7 of 22 (permalink) Old 01-29-2019, 02:46 PM Thread Starter
Learners License
 
Jael Ryan's Avatar
 
Join Date: Jan 2019
Posts: 30
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by waughoo View Post
@Jael Ryan , as @bluedevil6 says, solve those misfires pronto! I'm not sure how many miles you have on your long top, but the coils are a bit of a service item on these cars. It is unfortunate, but it seems that many people seem to start having issues at 100k miles. I would strongly suggest a full replacement of the coils and likely a set of plugs. The issue is that getting to them can be a bit of a problem and delaying the repair can cause significant expense and possible engine failure. I don't want to scare you there, but pre cat failure on these duratec v6 engines is well documented. I'd start with the misfire fix first. One thing I'd add too is that the harness clips that go into the coils can sometimes lose their pliability and they will break off the little clip that secures them into the coil. I had this problem and ended up using a small zip tie to make sure it would stay in place. It is not my favorite solution, but the only other resolution is to replace the plug at that given coil. I had bought the parts to do so but decided it was going to be so much work as there isn't much room to work on the harness at the coil location. I still have the clips but my zip tie solution is still working fine for the moment.
I will solve this pronto. My dad's helping me take it to a dealer to have it checked. The car has about 109500 miles.

Regards,
Jael Ryan
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jael Ryan is offline  
post #8 of 22 (permalink) Old 01-29-2019, 02:50 PM Thread Starter
Learners License
 
Jael Ryan's Avatar
 
Join Date: Jan 2019
Posts: 30
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by DrFeelGood View Post
Quote:
Originally Posted by Jael Ryan View Post
Hi I'm new in this forum. My car is throwing a lot of codes involving the EGR and the system Bank. I have a po303 po401 p2179 p2177 and many more does anyone know how to diagnose this or fix it?

Welcome to the form, we love our wagons (although I could be biased)


The P0303 is the killer, you gotta get this fixed. Usually I is remedies by new plugs and coils but moving cylinder 3 to another location and waiting for the code retuen would be a way to verify. (It is happened so many times on this forum that if you haven't replaced those items I would just do all 6)


The search bar in the upper right will take you straight to all those codes. There you can read what other people did to fix similar scenarios.


If I had to guess I would say either the EGR is clogged or the EGR purge valve solenoid is not working.
For the Lean codes make sure you do net have an intake air leak. The accordion hose running from the air cleaner is notorious.


OEM parts
Mazda AJTT-18-110 - Spark Plugs x6 (these will be Motorcraft AGSF 22FSCM)
DENSO 673 6005 - Ignition Coils x6
I checked the accordion hose and found no leak thus far with my miniscule car know how. My dad suggested taking it to Mazda for diagnostics and see what it'll need.
Crossing fingers it won't take all my tax money

Regards,
Jael Ryan
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jael Ryan is offline  
post #9 of 22 (permalink) Old 01-29-2019, 02:52 PM Thread Starter
Learners License
 
Jael Ryan's Avatar
 
Join Date: Jan 2019
Posts: 30
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Quote:
Originally Posted by DrFeelGood View Post
Quote:
Originally Posted by Jael Ryan View Post
Hi I'm new in this forum. My car is throwing a lot of codes involving the EGR and the system Bank. I have a po303 po401 p2179 p2177 and many more does anyone know how to diagnose this or fix it?

Welcome to the form, we love our wagons (although I could be biased)


The P0303 is the killer, you gotta get this fixed. Usually I is remedies by new plugs and coils but moving cylinder 3 to another location and waiting for the code retuen would be a way to verify. (It is happened so many times on this forum that if you haven't replaced those items I would just do all 6)


The search bar in the upper right will take you straight to all those codes. There you can read what other people did to fix similar scenarios.


If I had to guess I would say either the EGR is clogged or the EGR purge valve solenoid is not working.
For the Lean codes make sure you do net have an intake air leak. The accordion hose running from the air cleaner is notorious.


OEM parts
Mazda AJTT-18-110 - Spark Plugs x6 (these will be Motorcraft AGSF 22FSCM)
DENSO 673 6005 - Ignition Coils x6

PS......are aftermarket iridium plugs worth the buy?

Regards,
Jael Ryan
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jael Ryan is offline  
post #10 of 22 (permalink) Old 01-29-2019, 02:56 PM
Registered User
 
waughoo's Avatar
 
Join Date: Jan 2016
Location: Edmonds, WA
Posts: 1,803
Mentioned: 92 Post(s)
Tagged: 1 Thread(s)
Quoted: 422 Post(s)
Thanks: 7
Thanked 115 Times in 110 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Garage
iTrader: 0 reviews
Quote:
Originally Posted by Jael Ryan View Post

I checked the accordion hose and found no leak thus far with my miniscule car know how. My dad suggested taking it to Mazda for diagnostics and see what it'll need.
Crossing fingers it won't take all my tax money
Taking it into the dealer for a diagnostic is often a great solution. They have more vehicle specific knowledge than an independent and can often get to the crux of the problem with less labor. Regardless, I'd make sure you solve that misfire quickly. I'd replace all the coils to avoid future misfires as others fail. Keep us posted on how it goes.

Alex
2004 6s Wagon MTX - grocery hauler
---}
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
{---

MODS: Tinted windows, RX8s with 225/45 R18s,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
, and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
waughoo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome