Throwing so many codes, what is going on??? - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 1Likes
  • 1 Post By HerronScott
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 05-02-2016, 03:33 AM Thread Starter
Learners License
 
Join Date: Mar 2014
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Throwing so many codes, what is going on???

It seems every day my car just gets worse. If it's not falling apart cosmetically (headliner, bumpers, paint, frigging intermittent left blinker!, etc.) it's falling apart mechanically. Car's an 03 6s with about 160k miles. When I start the car it revs up then down and almost stalls, then up again, then back down and gets better when I start driving it. Plugged in my scanner and got these codes today.

P0022 - Powertrain - "A" camshaft position - Timing over retarded bank 2

P0171 - Powertrain - System too lean bank 1

P0304 - Powertrain - Cylinder 4 misfire detected

P0443 - Powertrain - Evaporative emission control system purge control valve circuit

I just read the sticky for the pcv valve. I'm going to try and inspect that tomorrow the best I can. Is all of this related and is my car long for this world?
spacegravity4me is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-02-2016, 07:51 AM
Registered User
 
HerronScott's Avatar
 
Join Date: Aug 2008
Location: Staunton, VA
Posts: 1,070
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 153 Post(s)
Thanks: 8
Thanked 131 Times in 108 Posts
Groans: 0
Groaned at 1 Time in 1 Post
Garage
iTrader: 0 reviews
I would say start with trying to find why you are too lean which may possible resolve the miss-fire (although that could be plug/coil).


Check your intake accordion hose for cracks first.


Scott
GerryB likes this.

2004 Mazda 6s GT MTX sports package
HerronScott is offline  
post #3 of 3 (permalink) Old 05-02-2016, 07:05 PM Thread Starter
Learners License
 
Join Date: Mar 2014
Posts: 38
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Groans: 1
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by HerronScott View Post
I would say start with trying to find why you are too lean which may possible resolve the miss-fire (although that could be plug/coil).


Check your intake accordion hose for cracks first.


Scott
Well I looked and the first thing I noticed is that the accordion hose has come lose from the intake again! They were just sitting next to each other. I had this problem earlier this year and I thought I fixed it. It doesn't seem to matter how hard I push the two things together or clamp them down they don't stay connected. They just don't line up right. If I had the money I'd just rip the thing out and replace it with a shortram intake.
spacegravity4me is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome