Click sound on front suspention - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 03-06-2017, 03:57 AM Thread Starter
Learners License
 
Frederick W J Swanepoel's Avatar
 
Join Date: May 2016
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Click sound on front suspention

Hi all
I noticed when I drive over a speed pump or dip in the road, there sometimes is a click sound coming from the fron suspention, drivers side, i cant seem to see anything out or order, yet the sound is persistant...
Frederick W J Swanepoel is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-11-2017, 01:42 PM
Registered User
 
Join Date: Jun 2014
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Check your tie rods. I'm getting this too, I'll let you know if replacing them fixes it, hopefully next week some time.
anomalous3 is offline  
post #3 of 4 (permalink) Old 03-19-2017, 04:58 AM
Learners License
 
Join Date: Feb 2017
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Originally Posted by anomalous3 View Post
Check your tie rods. I'm getting this too, I'll let you know if replacing them fixes it, hopefully next week some time.
A few pictures of the process would be greatly appreciated.
Oyabun is online now  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 03-19-2017, 11:31 AM
Registered User
 
Join Date: Jun 2014
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 0
Thanked 5 Times in 5 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
Garage
iTrader: 0 reviews
Well, I did the driver's side and that fixed it. Still going to do the passenger side today or Tuesday, will try to take pictures.
anomalous3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome