TSB01-037/06 (CEL: P2407) - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
Go Back   Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum > Technical / Performance / Model > Mazda 6 1st Generation (2002-2008) > Mazdaspeed6 > Speed6 Engine/Drivetrain
New User? Register
Mazda6Club.com is the premier Mazda 6 Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools
Old 10-09-2006, 01:06 PM   #1 (permalink)
Registered User
 
mick_estes's Avatar
 
Join Date: Jun 2006
Location: N. CA
Posts: 672
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 65
Thanked 22 Times in 18 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 3 reviews
Default

Just took the MS6 into dealer for a CEL. Got it a couple weeks ago but dealer was not stressed b/c it had been running normal. Anyway, they said it was due to P2407 and said they reprogrammed it per TSB01-037/06. No mods yet, only thing I've done to the car so far is the 4106E recall/reflash and airbox delete.

Paperwork says:
" Code P2407 Present in Memor[y] Reprogram PCM as per TSB01-037/06"


During the short drive between dealer and work (5-6 miles), couldn't really tell anything out of the norm. Although, merging from the slow lane from 50 to 80mph was worth about 10 minutes of giggles (but that's biz as usual with this car).

Sorry if this has been posted somewhere (did a quick search & only found stuff related to 4106E recall). Anyone know anything about this TSB? Any details out there about what it does, what it fixes etc?


__________________
2009 Infiniti G37S 6MT Sedan
2006 MazdaSpeed6 GT TiGray 60,171 ==> RIP (totaled)
mick_estes is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-09-2006, 01:24 PM   #2 (permalink)
Registered User
 
Alan's Avatar
 
Join Date: Dec 2005
Location: Plano, TX
Posts: 856
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

Quote:
Just took the MS6 into dealer for a CEL. Got it a couple weeks ago but dealer was not stressed b/c it had been running normal. Anyway, they said it was due to P2407 and said they reprogrammed it per TSB01-037/06. No mods yet, only thing I've done to the car so far is the 4106E recall/reflash and airbox delete.

Paperwork says:
" Code P2407 Present in Memor[y] Reprogram PCM as per TSB01-037/06"
During the short drive between dealer and work (5-6 miles), couldn't really tell anything out of the norm. Although, merging from the slow lane from 50 to 80mph was worth about 10 minutes of giggles (but that's biz as usual with this car).

Sorry if this has been posted somewhere (did a quick search & only found stuff related to 4106E recall). Anyone know anything about this TSB? Any details out there about what it does, what it fixes etc?
[/b]
I have not heard of this TSB.
I wonder if this is what the post 4106E flash is all about.
What is P2407, Evap leak detection?

Alan is offline   Reply With Quote Quick reply to this message
Old 10-09-2006, 01:54 PM   #3 (permalink)
Registered User
 
franchize's Avatar
 
Join Date: Feb 2006
Location: SOCAL -.-
Posts: 1,022
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 4 Times in 4 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

It's in the same range of EVAP voltage problems. I think it's an intermittent curcuit problem with the pump code.
__________________
Whitewater Pearl MazdaSpeed 6 GT Black Leather Sunroof Navigation
CP-E Standback™ 2 - CP-E CAI - CP-E FMIC - CP-E FullControl - TWM short shifter - CP-E Catback exhaust
HKS BPV - Tint 15% - LED Interior Lights - AUX MOD - Shark Fin Antenna - Defi-Link BF Boost Gauge
franchize is offline   Reply With Quote Quick reply to this message
Old 10-09-2006, 02:36 PM   #4 (permalink)
Registered User
 
Join Date: Aug 2006
Location: Fredericksburg, VA
Posts: 788
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 4
Thanked 12 Times in 8 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

I have been getting the same problem, but I haven't had a chance to get it in to the dealer yet...
__________________
2007 Trailblazer SS - stock for now
2006 Pontiac GTO - some mods
2006 Speed6 GT Red - Sold
jdeprato is offline   Reply With Quote Quick reply to this message
Old 10-09-2006, 10:36 PM   #5 (permalink)
Registered User
 
Join Date: Mar 2005
Posts: 182
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

I experienced the same CEL at 2000 miles. When I took my car into the dealership they tested the leak detection pump, and said it was faulty. I’ve gone a little over 2000 miles now without a problem.
__________________
2006 MS6 GT Titanium Gray Metallic
Mods: Shark Fin, Cobb AP, Cobb SRI, Auxmod
bhags is offline   Reply With Quote Quick reply to this message
Old 10-10-2006, 07:57 AM   #6 (permalink)
Registered User
 
Emptynapalm's Avatar
 
Join Date: Jan 2006
Location: Raymond N.H.
Posts: 359
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

Funny my CEL has been on for over a week while I wait till Wed to have a new "fuel pressure sensor" installed. I wonder if Mazda knows of these problems?
__________________
<span style="font-family:Comic Sans Ms">
2006 speed6 titanium - Sharkfin antenna - clear sidemarkers w/ tint - tinted rear 5 windows - HKS BOV w/ CP-E flange - CP-E CAI - CP-E battery tray w/ Odyssey Drycell™ battery - CP-E engine mount - Autometer Nexus Boost, EGT, & Oil Press. - Lotek triple guage pod - Whiteline 24mm rear sway bar - Custom 3" turboback dual 2.5" exit exhaust by www.synaptic3.com - TWM short shifter w/ bushings - smoked led rear reflectors - true Euro-tails - CP-E standback tuner - CP-E FMIC - other crap I don't feel like listing
</span>
Emptynapalm is offline   Reply With Quote Quick reply to this message
Old 10-10-2006, 08:23 AM   #7 (permalink)
Registered User
 
Join Date: Aug 2006
Location: Fredericksburg, VA
Posts: 788
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 4
Thanked 12 Times in 8 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

I have the latest flash, so my guess is that the leak detection pump is faulty on my car as well, I just need time to get it into the dealer...
__________________
2007 Trailblazer SS - stock for now
2006 Pontiac GTO - some mods
2006 Speed6 GT Red - Sold
jdeprato is offline   Reply With Quote Quick reply to this message
Old 10-10-2006, 11:48 AM   #8 (permalink)
Registered User
 
mick_estes's Avatar
 
Join Date: Jun 2006
Location: N. CA
Posts: 672
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 65
Thanked 22 Times in 18 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 3 reviews
Default

Quote:
I have the latest flash, so my guess is that the leak detection pump is faulty on my car as well, I just need time to get it into the dealer...
[/b]
PlatinumMS6...by latest flash are you talking about 4106E (power loss recall). From what I've read, it sounds like there different versions of the 4106E reflash file but I think this TSB/flash is something different. The dealer said ths TSB was specifically for people who got the P2407 CEL. I wish someone who runs in the Mazda circles could tell us more.

50 Mile Update....
Interestingly, now that I have about 50 miles on the car, I'm pleased with whatever it fixed. Although the power loss recall smoothed out power delivery (as many have reported), it still stumbled/stuttered/hesitated in various situations, typically it was under hard acceleration. This TSB seems to have finished where the Recall left off.

In these 50 miles since TSB, I've observed:
* Car seems to just run smoother (almost too smooth - seems quieter both under throttle and at idle)
* Power delivery has smoothed even more than after recall
* No degradation in performance and maybe even a little gain (for ex. now tires chirp when launching even when DSC is ON plus I notice power transferring to the rear (dull clunk) under hard launches with DSC on


__________________
2009 Infiniti G37S 6MT Sedan
2006 MazdaSpeed6 GT TiGray 60,171 ==> RIP (totaled)
mick_estes is offline   Reply With Quote Quick reply to this message
Old 10-10-2006, 05:48 PM   #9 (permalink)
Registered User
 
dsulli37's Avatar
 
Join Date: May 2006
Location: Ann Arbor/Southfield, MI
Posts: 680
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to dsulli37 Send a message via Yahoo to dsulli37
Default

I have the stumble during a hard push but when I turn off the DSC I notice it go away....mostly second gear WOT.
__________________
************************************
My babies:
2008 A4 2.0T Quattro w/APR 93 Octane Chip
2007 Altima SE 3.5L V6
2006 Mazdaspeed6 GT (Someone needs to buy this car)
dsulli37 is offline   Reply With Quote Quick reply to this message
Old 10-10-2006, 08:08 PM   #10 (permalink)
Registered User
 
Join Date: Aug 2006
Location: Fredericksburg, VA
Posts: 788
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 4
Thanked 12 Times in 8 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

thats weird, maybe THATS what my car is doing, i'll try that...after i get the light fixed tomorrow hopefully...
__________________
2007 Trailblazer SS - stock for now
2006 Pontiac GTO - some mods
2006 Speed6 GT Red - Sold
jdeprato is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 09:32 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2