does 2009 mazda6 have transmission oil filter need to be replaced? - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-30-2012, 11:30 AM Thread Starter
Learners License
 
Join Date: Oct 2011
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
does 2009 mazda6 have transmission oil filter need to be replaced?

I need to do a transmission oil change because it's looking brownish for my 2009 mazda6 V6, is there a servicable transmission oil filter that also need to be replaced?

Also just drain/fill or flush? dealer wants 169 i think for a flush.
michaelscai is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-30-2012, 02:36 PM
Registered User
 
Final Impact's Avatar
 
Join Date: Sep 2012
Location: USA, OR
Posts: 2,648
Mentioned: 105 Post(s)
Tagged: 1 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,115
Thanked 857 Times in 614 Posts
Groans: 0
Groaned at 2 Times in 2 Posts
iTrader: 0 reviews
V6, six speed ATX = AW6A-EL - negative! No filter, just a magnet. PS - I got 4 qts out of mine. 3 by pulling the plug, another qt with 5 sec start-up so the converter dumps "some" of its fluid to the pan.

Do not pore in more than 2.5 qts w/out starting it or it'll overfill and dump out the vent. i.e. only put in, what comes out before you start it - assuming it was full to begin with.

I filled it w/Royal purple MAX ATF. The manufacture says its synthetic product can be mixed as it meets the specs. JWS-3309, T-IV, and all that. Final Impacts running list of links that help solve issues

PS - in tiny print on your dipstick it should say T-IV.

2006 Mazda 6s GS Hatchback, Lapis Blue | AJ 3.0 & AW6A-EL 6 Spd, >101,000

__________________________________________________ __________________
V6 repair info here: FSM, MIL/CEL codes, P030X solved, Links to V6 threads
Final Impact is offline  
post #3 of 3 (permalink) Old 12-30-2012, 07:48 PM
Registered User
 
ozracin's Avatar
 
Join Date: Oct 2011
Location: Largo,FL
Posts: 245
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Thanks: 29
Thanked 21 Times in 20 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 1 reviews
Quote:
Originally Posted by michaelscai View Post
I need to do a transmission oil change because it's looking brownish for my 2009 mazda6 V6, is there a servicable transmission oil filter that also need to be replaced?

Also just drain/fill or flush? dealer wants 169 i think for a flush.
Where is the dipstick to check the transmission fluid?

Hydodipped engine cover | Fire Orange Powdercoated Injen CAI w/ Hydro-Shield | 15% Tint | LOC | 12" Memphis Audio in sealed box | Quantum Audio Amp |Enkei EKM3 18x7.5 Wrapped w/ Falken Ziex 912 235/45/18 tires | Smoked Taillights | B&G Springs | Audi style LED strip in headlights | H9 3000k fog lights | Custom engine cover | AWR Dog bone mount | custom cat-back exhaust w/ Raptor Mufflers

ozracin is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome