2011 6 Won't Start (Red Start Button + Red Key Light on Dash) - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 12-01-2012, 12:57 PM Thread Starter
Learners License
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
2011 6 Won't Start (Red Start Button + Red Key Light on Dash)

Hi,

I've got a UK spec 2011 2.2 Diesel Sport. I think it uses the same Advanced Key, Keyless Entry and Push Button start as the US model so I would be interested to see if anyone has seen this problem

Yesterday I tried to start it but when I depressed the clutch (the clutch is used instead of brake on the manual gearbox) the Start Button / Advanced Key light initially turned green, but then both changed to red as soon as I tried to start it and the car would not start. After that both the start button and the advanced key light would always appear red when trying to start the car.

I tried the spare key, tried replacing batteries in key fobs, tried the backup key/s in the ignition, etc, all to no avail. I could still lock / unlock without any issue.

The breakdown company arrived checked the main car battery but found no issues, they tried disconnecting the battery to reset to no avail, so finally towed me back to Mazda garage.

The Mazda garage got it going with their computer and reset the immobiliser, etc. My parents picked the key up while I was at work so I went to collect it.

I put my foot on the clutch and the Start Button and key light all lit up green! Great I thought, it's fixed, until I tried to start it and both turned red again and now they are red again whenever I press the clutch to try and start it.

It's still at a Mazda garage but they seem confused beyond plugging computer in and resetting the immobiliser. Has anyone come across this before or have any idea what could be triggering it or if there is any way of getting the car started if it happens again as my recovery company start charging for same fault call outs.

Thanks,
Craig
Craigy1D is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 12-01-2012, 10:27 PM
Registered User
 
Chuckie's Avatar
 
Join Date: Feb 2009
Location: Socal
Posts: 1,380
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 135 Post(s)
Thanks: 157
Thanked 213 Times in 179 Posts
Groans: 41
Groaned at 6 Times in 5 Posts
iTrader: 0 reviews
Will it start with the actual key? If not, it sounds like the clutch safety switch is going out or the piston is bent that indicates the clutch pedal is in and it's safe to start.



2009 Mazda 6s GT - Rotora BBK, KSport coilovers, 19" TSW, Injen CAI, Addco RSB, AWR rmm |
2012 Genesis Coupe Turbo
- ARK, DEPO, HKS, RMR, PA, Prodigy, Sequence, Stillen, Turbo XS |


Plasti dip is for tool handles.
Chuckie is offline  
post #3 of 5 (permalink) Old 12-02-2012, 08:08 AM Thread Starter
Learners License
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Thankyou for the reply. The actual key makes no difference and I still get a red start button and red key on the dash.

I'm not sure the clutch is the problem either as the start button and the key light on the dash light up in response to me depressing the clutch, they are just lighting up red instead of green.

It's got Mazda confused.

Thanks,
Craig
Craigy1D is offline  
post #4 of 5 (permalink) Old 12-02-2012, 05:59 PM Thread Starter
Learners License
 
Join Date: Dec 2012
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Just a theory, but is there an internal antenna used for the Advanced Key / Immobiliser? If so then if that were to have an issue then the computer would think someone is trying to start the car without the key and lock down.

Does anyone know the location of the internal antenna/s?
Craigy1D is offline  
post #5 of 5 (permalink) Old 12-24-2012, 04:36 AM
Registered User
 
Chuckie's Avatar
 
Join Date: Feb 2009
Location: Socal
Posts: 1,380
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 135 Post(s)
Thanks: 157
Thanked 213 Times in 179 Posts
Groans: 41
Groaned at 6 Times in 5 Posts
iTrader: 0 reviews
There are several throughout the car. I say the main car battery is toast.



2009 Mazda 6s GT - Rotora BBK, KSport coilovers, 19" TSW, Injen CAI, Addco RSB, AWR rmm |
2012 Genesis Coupe Turbo
- ARK, DEPO, HKS, RMR, PA, Prodigy, Sequence, Stillen, Turbo XS |


Plasti dip is for tool handles.
Chuckie is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome