A/C not working - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
Go Back   Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum > Technical / Performance / Model > Mazda 6 1st Generation (2002-2008) > Engine / Drivetrain > 3.0L V6
New User? Register
Mazda6Club.com is the premier Mazda 6 Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools
Old 03-26-2009, 07:54 PM   #1 (permalink)
Learners License
 
Join Date: Nov 2008
Location: Bangor, Washington
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

i just installed a K&N cold air intake and new headers and exhaust and for some reason now my air conditioning doesn"t work.... the light turns on saying that its blowing a/c but the compressor never turns on and the air is the same temp as outside air, it blows air just fine and the heater works but no cooling of the air. i was wondering if maybe since i unhooked the battery for the work if maybe there is some sort of reset that you have to do? don't know what to do but i live in the south and it's about to get hot so if anyone has any suggestions please let me know!!!!

Thanks
littlenuke4all is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-26-2009, 11:46 PM   #2 (permalink)
Registered User
 
KCV6's Avatar
 
Join Date: Apr 2004
Location: Adelaide, Australia
Posts: 113
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

No reset required. I would be checking the wire going to the AC cluch coil (the plug on the AC compressor). when off there should be 0Vdc in the pin, when on there should be 12Vdc present. If this is good then the compressor is toast (well the coil is). If there is no 12Vdc, check the AC fuse and relay. If all is good then the climate control and fan control is not working properly.

Cheers...... Mark
__________________
03 6 I4 classic hatch
07 6 MPS

I HAVE NO FRIENDS BUT MY CARS DON'T CARE
KCV6 is offline   Reply With Quote Quick reply to this message
Old 03-28-2009, 12:41 AM   #3 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Default

take it in for service the new fuse will cost ya $1 plus the obnoxious diagnostic fee
__________________
04 v6 MTX - 238.8 WHP (w obx headers) - 17" Enkei RS+M rims with Goodyear Eagle 215/45. Performance Mods: AEM CAI, Magnaflow Mufflers w/ customized exhaust, CP-E Headers, Apexi SAFC II, optimized throttle body, Racing Beat Rear Sway Bar, EGR Mod, component polk system with a 12" sub and alpine amps, 7k HID headlights, DDE's, and more. All self installed! check out my APEXI install/dyno/settings thread and my OBX header install/dyno/APEXI settings thread To come: optimizing exhaust WTB: steel grey eyelids
hot6onaplatter is offline   Reply With Quote Quick reply to this message
Old 03-28-2009, 01:11 AM   #4 (permalink)
Learners License
 
Join Date: Nov 2008
Location: Bangor, Washington
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

QUOTE (hot6onaplatter @ Mar 28 2009, 12:41 AM)
Quote:
take it in for service the new fuse will cost ya $1 plus the obnoxious diagnostic fee[/b]

i checked all of the fuses though... all of the fuses and relays are good, the indications inside all say that everything is working, i had the freon checked and it's good, and i ran a wire straight from the battery to the compressor and it turned on and worked fine..... it's just that for some reason it's not getting the power signal when it should and i had a mechanic look at it and he was stumped... he even hooked up his computer to my car and ran a check on it and nothing came up to cause an issue..... i really don't want to take it to a mazda dealer cuz i know they're going to charge me an arm and a leg so if there could be any other reason you guys can think of please let me know


Thanks
littlenuke4all is offline   Reply With Quote Quick reply to this message
Old 03-28-2009, 01:29 AM   #5 (permalink)
Learners License
 
Join Date: Feb 2008
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Default

if you checked the wire going to the compressor and you have no voltage check where the pressure switch is if thats unplugged or maybe the wiring is sitting against the header the ac control head wont activate the compressor clutch
rtsvtec2004 is offline   Reply With Quote Quick reply to this message
Old 03-29-2009, 01:08 PM   #6 (permalink)
Registered User
 
Join Date: Jul 2006
Posts: 471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Groans: 0
Groaned at 1 Time in 1 Post
iTrader: 0 reviews
Default

there are many hidden fuses (not in the fuse box), im not sure if you know where they are but yeah thats my bet
__________________
04 v6 MTX - 238.8 WHP (w obx headers) - 17" Enkei RS+M rims with Goodyear Eagle 215/45. Performance Mods: AEM CAI, Magnaflow Mufflers w/ customized exhaust, CP-E Headers, Apexi SAFC II, optimized throttle body, Racing Beat Rear Sway Bar, EGR Mod, component polk system with a 12" sub and alpine amps, 7k HID headlights, DDE's, and more. All self installed! check out my APEXI install/dyno/settings thread and my OBX header install/dyno/APEXI settings thread To come: optimizing exhaust WTB: steel grey eyelids
hot6onaplatter is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 01:57 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.3.2