Engine rattle when accelerating - Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum
User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 36 (permalink) Old 12-29-2005, 09:21 AM Thread Starter
Learners License
 
Join Date: Dec 2005
Location: Louisville, Ky
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
I have a rattle coming from the engine compartment when accelerating. To me it does not sound like valve knock or lifters. It is definitely more dominant in cold weather. It does it when the engine is at normal operating temp as well.

To me it sounds like a heat shield or some real light metal material. I have searched the car high and low with no luck. I took it to the dealership and they blamed it on the fact that I was 560 miles over my 3000 mile oil change. They changed the oil and said the problem was fixed and it isn't.

Anyone else have this issue?

Thanks in advance.
rwing21 is offline  
Sponsored Links
Advertisement
 
post #2 of 36 (permalink) Old 12-29-2005, 01:58 PM
Super Moderator
 
MrTea's Avatar
 
Join Date: Mar 2003
Location: Huntington Beach, CA
Posts: 9,060
Mentioned: 8 Post(s)
Tagged: 1 Thread(s)
Quoted: 35 Post(s)
Thanks: 7
Thanked 202 Times in 147 Posts
Groans: 1
Groaned at 2 Times in 2 Posts
iTrader: 0 reviews
Send a message via AIM to MrTea Send a message via MSN to MrTea
no ideas, but is it a consistant sound, or more random? might help us trouble shoot a bit

'03 Lapis(mostly) 6i...Tranny swap by Gillis Motorsports : MTX-75 5speed tranny, 4.06 gears, Torsen LSD & chromoly axles, Engine build by Gillis Motorsports: 9:1 Supertech Pistons, Crower rods, Supertech valves, springs & retainers, ARP head & main studs, F2 Stage2 Turbo, Custom F2 engine/tranny mounts, 3" Turboback exhaust, Tein Basic Coilovers, Brembo Big Brake Kit and Rotora Rear Rotors, RacingBeat Front & Rear Sways, Seibon OEM hood, VF Engineering rear engine mount, Powdercoated Valvecover, TEIN hood dampers, Some sort of Body Kit from some company usually last dyno 8/23, 10psi...260HP/267TQ

Still need: Seat, cage, Gillis suspension...then i'm DONE!!

MrTea is offline  
post #3 of 36 (permalink) Old 12-29-2005, 02:13 PM
Registered User
 
Join Date: Apr 2005
Location: Woodbridge, CT
Posts: 1,694
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via AIM to lapis_blue_beast Send a message via MSN to lapis_blue_beast
Quote:
I have a rattle coming from the engine compartment when accelerating. To me it does not sound like valve knock or lifters. It is definitely more dominant in cold weather. It does it when the engine is at normal operating temp as well.

To me it sounds like a heat shield or some real light metal material. I have searched the car high and low with no luck. I took it to the dealership and they blamed it on the fact that I was 560 miles over my 3000 mile oil change. They changed the oil and said the problem was fixed and it isn't.

Anyone else have this issue?

Thanks in advance.
[/b]
Go back to the dealer and tell them that they're fuckheads. Then open up your manual and show them that the car goes 5k between oil changes. Then tell them its not fixed.

Reliable Web Hosting | Clustered Web Hosting | ASP Hosting | <a href="http://www.reliablesite.net/v3/reseller.asp" target="_blank">Reseller Hosting | Dedicated Servers
</a></span>
2004 Lapis Blue Mazda6 S 5 Speed Auto - RIP
2005 Redfire Metallic Mazda6 S 6 Speed Auto
2004 Blue BMW 530i 6 Speed Auto
2004 Jet Black BMW Z4 3.0i 6 Speed Stick
1999 Brilliant Black Miata 5 Speed Stick - <span style="color:red">Sold!
lapis_blue_beast is offline  
post #4 of 36 (permalink) Old 12-29-2005, 03:57 PM Thread Starter
Learners License
 
Join Date: Dec 2005
Location: Louisville, Ky
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
Go back to the dealer and tell them that they're fuckheads. Then open up your manual and show them that the car goes 5k between oil changes. Then tell them its not fixed.
[/b]
Funny you mention that. I told them that technically the owners manual specifies that you could go 7500 miles on a oil change. I was told not to take the manual to heart. Mazda claims that Mittsibushi does the same thing.

I also mentioned that I change the oil every 5000 miles and they said this was the starting point for troubleshooting the issue. I think they just wanted the cash for the oil change. Oh well, it just about needed the oil change anyway.
Quote:
no ideas, but is it a consistant sound, or more random? might help us trouble shoot a bit
[/b]
Consistant when cold. However, whent he engine is up to normal operating temp, it only does it when accelerating somewhere between 3 and 4000 rpm.

I did just find a Service Bulletin that applies to my car regarding the auto tensioner. (Bulletin No: 01-018/05 issued on 6/24/2005) I wonder why the dealership did not mention this. I will take it back to the dealership and see if this fixes it.
rwing21 is offline  
post #5 of 36 (permalink) Old 12-30-2005, 04:08 PM
Registered User
 
twowheelin's Avatar
 
Join Date: Jun 2004
Location: ElvisLand, TN
Posts: 1,610
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 11 Times in 11 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Might want to check the exhaust shields and the fuel line heat shield by the firewall to see if maybe there is any buzzing or rattling when you tap on them or 'flick' them with a finger. Rattles like these drive me crazy.... If the rattle only happens on hard loads, maybe it's pinging? (Test out with some mid-grade gas )

03-6i ATX: Hawk ceramic pads, SS lines, PowerSlot Rotors, Tanabe-NFs+Konis, Kosei K1-TS, Spin On Conversion, Custom CAI/MAF, 2 1/4" Exhaust, Optimized TB, Adjustable Fan Controller CordovaMotorsports.com (An RPM Customer!)
twowheelin is offline  
post #6 of 36 (permalink) Old 01-09-2006, 01:32 PM Thread Starter
Learners License
 
Join Date: Dec 2005
Location: Louisville, Ky
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Update: Car was back in the shop this time for a noisy fuel pump. I also had the tech check out the engine rattle. This time he took the car home and drove it into work the next day so the motor would be cold. He heard the rattle just as I explained it. He replaced the auto tensioner pulley and said that this fixed the issue.

Nope. Same rattle when the engine is cold. Any suggestions??
rwing21 is offline  
post #7 of 36 (permalink) Old 01-17-2006, 10:35 PM
Registered User
 
Join Date: Jul 2003
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
No issues here. Make sure oil level is correct.
Then, track the problem down.
Visit another dealer.

http://www2.northerntool.com/product-1/385487.htm
deadrx7conv is offline  
post #8 of 36 (permalink) Old 01-19-2006, 01:20 AM
Registered User
 
TommyBoy44's Avatar
 
Join Date: Dec 2005
Location: Wichita, Ks
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
i know exactly what you are talking about with the rattle noise. my car just started doing the same thing. the sound of mine seems to come from were the alternater is on the passenger side. i drive the i4 to give you an example. lets say that you pull up to a stop sign and start to take off. the noise comes on as you hit the 1500 rpm range and then goes away about 2 - 2500 range. not sure because i cant here because of engine noise or not (like loud rev.) is this the same problem Rwing21
TommyBoy44 is offline  
post #9 of 36 (permalink) Old 02-14-2006, 02:16 PM
Registered User
 
Join Date: Aug 2005
Location: Mesa, AZ
Posts: 79
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Send a message via Yahoo to stevem62005
I have the same problem except I can only hear it with the windows up and it happens 3700-4000rpm mark. It makes this rattle noise except mine seems to come from around my cold air intake. Dont have any ideas what it is though. Some help would be greatly appreciated.

2005 MAZDA 6i MTX VOLCANIC RED mods=Injen cold air, Magnaflow cat back, Mazdaspeed SS, Eibach pro-kit, awr speed 6 mount(YES IT FITS), advanced timing mod, custom grill, tinted headlight housing,VHT tinted taillights, debaged, door guards removed, painted engine cover and calipers red
stevem62005 is offline  
post #10 of 36 (permalink) Old 03-05-2006, 12:09 AM Thread Starter
Learners License
 
Join Date: Dec 2005
Location: Louisville, Ky
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Groans: 0
Groaned at 0 Times in 0 Posts
iTrader: 0 reviews
Quote:
i know exactly what you are talking about with the rattle noise. my car just started doing the same thing. the sound of mine seems to come from were the alternater is on the passenger side. i drive the i4 to give you an example. lets say that you pull up to a stop sign and start to take off. the noise comes on as you hit the 1500 rpm range and then goes away about 2 - 2500 range. not sure because i cant here because of engine noise or not (like loud rev.) is this the same problem Rwing21
[/b]
Sorry for the delay. Sounds close to the same. However, here lately mine is getting more consistent. I am going to take it back to the dealer soon. It used to be only on a cold engine that this was an issue. However now, if I accelerate normally, I am hearing it now around the 3000 - 3500 on a warm engine. Previously, I was only hearing it on a cold engine.


Quote:
I have the same problem except I can only hear it with the windows up and it happens 3700-4000rpm mark. It makes this rattle noise except mine seems to come from around my cold air intake. Dont have any ideas what it is though. Some help would be greatly appreciated.
[/b]
If I find out what it is causing this, I will post back.
rwing21 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Mazda 6 Forums : Mazda 6 Forum / Mazda Atenza Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome